Jump to content
  • 0
imMetallic

Driving Force GT Wheel Degrees Issue

Question

Hai.

 

Been a while since I've touched ETS2 MP because I have an outdated version of the launcher although I downloaded it just then. O_O

 

Anyway that's not the issue, its the game in general. My Driving Force GT wheel is used to drive. If I turn 90 degrees, it does it but it goes past the wheel. So if I hold on 90 degrees turn, the wheel will turn 90 degrees and over and continue until I resume my wheel back to 0 degrees. It's damn annoying, Please help!

Share this post


Link to post
Share on other sites

20 answers to this question

Recommended Posts

  • 0
Guest LIGHTOFGOD

Moved to Help Section

Share this post


Link to post
Share on other sites
  • 0

Can you show the "Controllers" menu in game options? There's a chance that you've selected wrong controller type. Also, you can adjust the range of the wheel in either Logitech Profiler, or in the test page after pressing "Settings" button. You can also set 900 degree angle by pressing cross button while holding START + SELECT.

Share this post


Link to post
Share on other sites
  • 0

Have you bound in keyboard controls your wheel to turn left and right (where A and D is)? Try checking there, your wheel shouldn't be bound to left and right, only the other buttons probably should (I bound my pedals there).

Share this post


Link to post
Share on other sites
  • 0

Cheers for assistance guys but I have a feeling you guys don’t understand the issue I’m in. I tried to elaborate but it’s one of those technology funny things you can’t explain haha. I’ve made a short clip.

 

 

Watch how I turn the wheel 75 degrees and the ingame wheel just automatically goes around ignoring my idle 75degress position.

 

The wheel is useable and can drive normally but I never can do even 90 degrees turn because my wheel does it automatically. 

 

All my control settings are on Standard/default, only the sensitivity is changed because default sensitivity is fucked.

 

Ignore my dirty desk, need to clean it :)

 

Thanks All

 

Edited by Ser Valence

Share this post


Link to post
Share on other sites
  • 0

Okay now I understand, and I think that there's no solution for that. Your wheel can only turn a few degrees, but the virtual wheel turns a lot more, I don't think that is anything possible to do with it.

Share this post


Link to post
Share on other sites
  • 0

@Ser Valence, from what you've provided it seems that you have set "Joystick, Gamepad" controller type in "Controllers" menu of the game settings. Can you show the screenshot of said menu? With such screenshot we can check if the setting about control type is correct. 

Share this post


Link to post
Share on other sites
  • 0

It has to be something with the settings IMO. I've used the same wheel and had no problems at all. Go to the Keys/Buttons settings and make sure to "Unassign" all related to steering, accelerating and braking. Then, in Controls, you need to assign each "axis" to the wheel's steering, accelerating and braking. I used to have steering sensivity at max, non-linearity minimum.


Some screenshots (I'm using a G27 now, but most general settings are the same)

Spoiler

 

03.11.2018-19.56.36

Here, you'll need to change H-Shifter to Automatic or Sequential. If you choose Automatic, you may want to look into the "Adaptive automatic transmission", to make it be more "Eco" or more "Power" aimed.

 

Spoiler

 

03.11.2018-19.59.54

This is where you assign your wheel and pedals. It should be something similar to that, just click on the control you want to assign and then you move the wheel or step on the corresponding pedal.

 

Spoiler

 

03.11.2018-20.02.28

These are the keys you need to have unassigned. For Shift up and Down, you can assign them to the stick in the DFGT, the wheel's side pads or just leave them if your going to use automatic gearbox and prefer the keyboard.

 

 

Spoiler

03.11.2018-20.07.41

These are my settings in the Logitech Profiler "device global settings" (I'm not sure what it will be in English, mine is in Spanish).

Try these and if your problem is not solved, we'll keep searching 

Edited by FernandoCR [ESP]
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I had this same problem. I downloaded Logitech Profiler Software then I made a profile for EST2. (http://support.logitech.com/en_us/product/driving-force-gt/downloads  From this website you can download LPS)
Here are my options in Profiler:

 

Spoiler

XvmSDvM.png


When I started the game my DFGT had only 180o. Then I was back to "Default settings" and it start working.

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

Hey @JJay

 

Very useful, thanks. My problem is solved but one thing. The wheel box is now, rattling? I can drive normally but coming out of the box the wheel is mounted on, it’s vibrating and rattling, like a lawnmower. Did you ever come against this problem?

 

Thanks!

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

@Ser Valence It' normal. Maybe try change "Engine Vibrations" of coure if I good translated this. Look on my settings. You have vibrations because your DFGT is in straight position. If you know what I mean. When you do little turn right or left you'll haven't vibrations. You can change Profiler's settings if you want. I made this setting for my self.

 

Spoiler

6zs9NDf.png

Spoiler

lk6u4Sx.png

 

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

Okay, all issues about my controls are solved. Thanks guys!

 

That Other ets2mp problem is still in the way, but’s it’s for another day.

 

I know, avalanches of problems, haven’t solved, trying get into it after years.

 

Cheers Lads

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...