Jump to content

Recommended Posts

10 hours ago, Seba6PL said:

Can't wait for 1.38 support! I played 1.38 and did some progress so I can't downgrade to 1.37 to play the Multiplayer.

The TruckersMP development team does a great job.

I think it's done when it's done.

Always remember that TruckersMP is not a right but a privilege. ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...