Jump to content
  • 0
1remusjmecherul

Cannot validate game version. Help?

Question

15 answers to this question

Recommended Posts

  • 0

I too, am having this problem. I have Windows XP (out dated, I know) and Ubuntu 14.04. Both are on different Hard Drives. I did everything that you guys said to do, and No such luck. If anyone can help that would make me really happy.

 

Thanks!

Multiplayer does not start now on WinXP,it's time to change you system to Win 7/8/10 x64
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

Hello and welcome to the forums! :D

It sounds like your problem is due to you using Windows XP, which I believe to be unsupported now by MP. Ubuntu (Linux in general) is unsupported by MP. However I've given my usual advice below for this problem in case it works on your windows installation.

You can obtain a product key and then download a Windows ISO from this webpage: https://www.microsoft.com/en-gb/software-download/home

1. *Removed about Antivirus*
2. Run Steam as administrator (Right click steam and run as administrator)
3. Go to library, right click Euro Truck Simulator 2 and then click properties
4. Go to betas and opt out of all betas
5. Go to local files and Verify Game Files

Try again with MP. If this doesn't work, then continue:

7. Go to control panel, add or remove programs and uninstall ETS2MP
8. Go to C:\Users\username\My Documents and delete ETS2MP folder
9. Go to ets2mp.com and download the latest client
10. Go through setup. MP should be installed to C:\Program Files (x86)\Euro Truck Simulator 2 Multiplayer
11. Choose your ETS2 SP directory, which should be:

C:\Program Files (x86)\Steam\steamapps\common\Euro Truck Simulator 2

12. Try again with MP, making sure you right click it and click Run as Administrator.

If this doesn't work, create a ticket at: https://ets2mp.com/support/ :)

Edited by El1teZombiezHD
Removed Point about antivirus

Share this post


Link to post
Share on other sites
  • 0

Now I'm getting this error "Cannot validate game version.Would you like to try again?" It was working all well this week until say Wednesday or Thursday Now can't play at all.

What i have tried.

-Reinstall the multiplayer

-Reinstall the base game

-Run As Administrator

-Have opt out and in of betas

-Verify Game Files

Also so it's not letting me on this site for some reason i am doing this on my iPad, i have reinstalled this game 2 or 3 times now I just don't understand it. also I was getting white snow dots in mp to even though I didn't install the winter mod strange it only comes up after 15 or 20 minutes in game.

Update: I have fixed multiplayer guys.. my desktop time clock was showing an outdated time so all I did was update the time and tried the game again and multiplayer is now working and the site is working again now so try this people if you haven't

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...