Jump to content
  • 0

Question

Hello, fellow Truckers!

I have been playing mp for a while and not had a single problem, but today I tried purchasing a new truck. I configured it as I wanted and it said: "purchase complete". Then I went to save it, to head for work. When I came back home I fired up mp and my profile. But it didn't show my new truck. I then bought the truck again, without customizing. When I went to save I made sure it saved, but it didn't. I restarted the game and could then save without buying a truck. But if I purchased a truck, it didn't save.  I tried purchasing a trailer, and then I could save. But new truck no save.  I read a few old topics here and tried some of their suggestions. Disable Antivirus, Run as administrator, clear cache. But it still didn't work.

All help is appreciated 

Drive safe!

Share this post


Link to post
Share on other sites

20 answers to this question

Recommended Posts

  • 0
 
 
 
44 minutes ago, MrJonton01 [GER] said:

Hey!

 

Is your profile connected and synchronized with the Steam cloud?

Or do you have a local profile for ETS2?

 

~ MrJonton01

My MP profile is not synchronized with the steam cloud, I have it local. Should I connect it to the steam cloud?

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, The-Night_-Driver said:

My MP profile is not synchronized with the steam cloud, I have it local. Should I connect it to the steam cloud?

Hmm...

I don't really think that that would help.

Do I understand it correctly, that only when you buy trucks they don't get saved?

Does your money balance get lower or does it stay the same?

 

~ MrJonton01

Share this post


Link to post
Share on other sites
  • 0
11 hours ago, MrJonton01 [GER] said:

Hmm...

I don't really think that that would help.

Do I understand it correctly, that only when you buy trucks they don't get saved?

Does your money balance get lower or does it stay the same?

 

~ MrJonton01

It stays the same, it's like after I bought a truck it refuses to save. Doesn't matter if I overwrite old save or if I create a new save file, or autosaving. 

Share this post


Link to post
Share on other sites
  • 0

Hello,

 

I'm not quite sure but it could be due to (if you had/currently still have) certain mods installed previously from the steam workshop or manually installed through your folders that's bugging your save.

 

May I recommend you creating a new profile from scratch solely for TMP use and without any mods enabled on either/both sim games that you have available and check once again?

I hope it helps :)

Share this post


Link to post
Share on other sites
  • 0

Hello!

Sound like a plausible idea, but the thing is that I don't have any active mods on my mp profile. It was created from scratch and haven't had a single mod active on that profile, on my second profile for sp I have a few mods active, but they shouldn't interfere with each other? 

 

Thanks for everyone trying to help!

Share this post


Link to post
Share on other sites
  • 0
10 hours ago, The-Night_-Driver said:

Hello!

Sound like a plausible idea, but the thing is that I don't have any active mods on my mp profile. It was created from scratch and haven't had a single mod active on that profile, on my second profile for sp I have a few mods active, but they shouldn't interfere with each other? 

 

Thanks for everyone trying to help!

Have you already tried completely reinstalling the game? You only mentioned that you checked the game cache.

 

~ MrJonton01

Share this post


Link to post
Share on other sites
  • 0

Hello @The-Night_-Driver,

 

I might have an idea, to atleast figure out if your game is saving properly. But for that we need to enable the console

 

1: Go to the Euro Truck Simulator 2 folder located in your Documents folder. It's normally somewhere here: C:\Users\YourName\Documents\Euro Truck Simulator 2.

2: Open config.cfg with notepad.

3: Search for uset g_developer and change the "0" to a "1".

4: Search for uset g_console and change the "0" to a "1".

5: Start your game, load your save. And press the ~ key when your are ingame.

 

You will see the console on the top left at this point. Close the console, save the game, and open the console again.

 

What we are looking for here is a line that says: 'creating save game file'.

And if everything goes well it shouldn't give any errors after that  'creating save game file' line.

 

 

QfNZuH6.png

 

It seems like your game is confused by, something, when saving the game. So I hope this gives us some information on what is causing that.

 

Good luck!

Happy Trucking ETS2

 

Share this post


Link to post
Share on other sites
  • 0
 
 
 
 
 
 
 
6
5 hours ago, Happy Trucking ETS2 said:

Hello @The-Night_-Driver,

 

I might have an idea, to atleast figure out if your game is saving properly. But for that we need to enable the console

 

1: Go to the Euro Truck Simulator 2 folder located in your Documents folder. It's normally somewhere here: C:\Users\YourName\Documents\Euro Truck Simulator 2.

2: Open config.cfg with notepad.

3: Search for uset g_developer and change the "0" to a "1".

4: Search for uset g_console and change the "0" to a "1".

5: Start your game, load your save. And press the ~ key when your are ingame.

 

You will see the console on the top left at this point. Close the console, save the game, and open the console again.

 

What we are looking for here is a line that says: 'creating save game file'.

And if everything goes well it shouldn't give any errors after that  'creating save game file' line.

 

 

QfNZuH6.png

 

It seems like your game is confused by, something, when saving the game. So I hope this gives us some information on what is causing that.

 

Good luck!

Happy Trucking ETS2

 

Hello!

I followed your guide and came up with this message after trying to save. (See image)

Any idea how to fix? Or should I try @MrJonton01 [GER] ´s suggestion of reinstalling the game? Thanks 

20190523164302_1.jpg

Share this post


Link to post
Share on other sites
  • 0

Hello @The-Night_-Driver,

 

It looks like one of your drivers is having a problem with a truck. In your case it is 'driver.189'.

That doesn't tell alot, but something your could do (if you don't have aloooot of drivers and trucks atleast), is dismissing the driver that uses a truck that is in your possession. Or driving that truck yourself.

 

Do you have alot of drivers in this save that you are using?

 

 

 

Share this post


Link to post
Share on other sites
  • 0

Hello @Happy Trucking ETS2

I have 7 drivers including myself, so 6 other drivers. I don't really understand what you mean by "is dismissing the driver that uses a truck that is in your possession. Or driving that truck yourself"

What driver should I fire you mean? I´ll attach a screenshot of the hub "my drivers" I don't know if you can help me by such a pic.  Sorry if I don't understand

(sorry for low quality, the file upload restriction)

My drivers ETS2.jpg

Share this post


Link to post
Share on other sites
  • 0

@The-Night_-Driver

 

What I think the console was saying, is that one of your drivers is trying to use a truck, but can't, for whatever reason. And it 'could' be that one of your drivers, or trucks is bugged.

To test this out, try to dismiss all the drivers you have hired(so they don't use a truck), and make a new save (name it test or something for safety). And see if that helps.

 

Good luck!

Share this post


Link to post
Share on other sites
  • 0

Hi @Happy Trucking ETS2!

I tried dismissing every one of my drivers, so there were only me left. But still it didnt work. I then tried putting myself with no truck, but still no...

 

I will reinstall mp in case something got bad. Edit: Reinstalled now, but still it doesnt save, it continues to display that same error message in the console.

Share this post


Link to post
Share on other sites
  • 0

@The-Night_-Driver

 

This is a tricky one.

I think the only way we can figure out if this actually has to do with the installation of TruckersMP/Euro Truck Simulator 2, or the savegame being the problem, is by letting someone else try your save on their computer.

 

Something else that could work is if you have a laptop for example. 

If anyone else has an other suggestion please try and help.

The last thing I can think of if this doesn't work is editing your savefile to remove the 'bug', but even that is not guaranteed to work.

Happy Trucking ETS2

Share this post


Link to post
Share on other sites
  • 0

 @Happy Trucking ETS2

I must agree that this is a tricky one. What you said to test if it was the installation or savegame I did. I copied my savegame onto a flash drive and then went to my other pc and started it up there on the save. But I still couldn't save, after I enabled console on the other pc I checked and it is still the same error message. So I guess this rules out the installation, so it must be the savegame? 

 

How do you edit a savefile? Better to try than not I guess...

 

Either way; Thank You for trying to help me, appreciate it!

 

Share this post


Link to post
Share on other sites
  • 0

Hello @The-Night_-Driver

 

I used to face the same problem a while ago for a some reason as well. As I had just re-installed the game back then, I'm pretty sure that the problem isn't caused by any certain modifications. I'm already aware of that you said that your profile isn't synchronized with Steam Cloud, but double checking it wouldn't be too bad idea either as the Steam cloud saving seems to be enabled by default nowadays. Just wanted to point out this as it was probably the reason which caused my progress not being saved. 

Spoiler

B6B5D8BE18A0D7BC3EDDF8DFB239A699E343EEE0

Or alternatively, after starting up the game press on 'Edit Profile' and ensure that this box is unchecked there. As far as I understood, the problem also occurs when creating a new profile - if so, ensure that the box about Steam Cloud saving is disabled when creating a new profile as well.

 

If the profile isn't synchronized with Steam cloud and the autosave isn't working correctly for whatever reason, saving the game manually should at least solve the issue unless there's something wrong with the installation path of your game. Not too sure if you've already tried it - you probably have - but try to save the game manually to see if it helps. If it doesn't, is there any chance that you can download a new profile (e.g. from here) and test if the progress on the downloaded save is being saved correctly? But yeah, if the problem occurs on more than one PC/laptop, there probably isn't anything wrong with the installation path of your game.

Share this post


Link to post
Share on other sites
  • 0

Hi @MHT_

I just double checked that it ain't synced to steam cloud, and it ain't.  I already tried manual saving it, many times. But it still doesn't save. 

I downloaded a save from ets2.lt and ran it. And then it saved no problems. As I said in my original post it only doesn't save when I purchase a new truck, so I don't know what is causing it.  

 

 

Share this post


Link to post
Share on other sites
  • 0

I solved it!

After trying all ideas here, I decided to do some own digging (which I should have done at the start) and eventually found the problem after a few hours. Apparently, there were some issues when I traded in my old truck for the new. It didn't have anything to do with the new truck, but the old truck made the game flip out ¯\_(ツ)_/¯

 

Either way, I hot fixed it by selling my truck instead of trading it in, and now I can save the game! 

 

I want to thank for everyone's help on this topic, and it gave me some new insights!:check: So this topic can now be moved to solved?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...