Jump to content
  • 0

G29 steering rotation


maka_paka88
 Share

Question

Hi,

I have just bought a g29 and just played over 18 hours. Now when i turn left or right, it goes all the way to that side. I didn't change any settings. What have i done so far:

1. Uninstall and reinstall LGS 9.02 drivers

2. Uninstall ETS from steam and reinstall it.

3. Tried different usb port and No luck

4. Play around with sensivity on ets 2 controller

Hopefully this forum could help me to fix this issue

Link to comment
Share on other sites

24 answers to this question

Recommended Posts

  • 0

Hello @maka_paka88,

 

The thing that is causing this is most likely a in-game issue and not a issue with your G29. Of course there is always a chance of hardware failures but I doubt that is the case. 

 

Try going in-game and changing your steering non-linearity setting all the way to the left and move the steering sensitivity to 50%.

 

I hope this helps you, and I hope we can get you back in-game with your G29 working as intended. 

 

Kind Regards, 

NickThe0ne 

smol_size.png.d3544591bca137e20b2ec7bc6cbf68d2.png

Discord: discord.io/BringVTC    |    Bring Website: BringVTC.com

 

Link to comment
Share on other sites

  • 0

Hi Soul Knight and NicktheOne,

My settings are exactly same with those on youtubers and still doesn't work. And my sensitivity went to max while non linearity set to 0. I just played four days and suddenly the fifth day, the steering went loose when turning. I will show you in youtube once i upload the video.

Cheers

Link to comment
Share on other sites

  • 0
1 hour ago, Maka_paka said:

Hi Soul Knight and NicktheOne,

My settings are exactly same with those on youtubers and still doesn't work. And my sensitivity went to max while non linearity set to 0. I just played four days and suddenly the fifth day, the steering went loose when turning. I will show you in youtube once i upload the video.

Cheers

 

I had some slightly similar issues with my G29 earlier before. You'll want to go into your LGS program, and check the following for the settings.

 

1. Select your wheel on the bottom bar.

2. Select Default Profile within your profiles. Then click on the steering wheel option. Wheel Operating Range should be set to 900 degrees, and for me, I have Centering Spring enabled and set to 100% with a Wheel Sensitivity of 50% (You can play around with it and adjust from there to your liking)

3. Select your Euro Truck Simulator Profile at the top, and adjust to the same settings you set for Default.

 

I recommend setting both Default and the ETS profiles, as LGS is a bit picky and will sometimes pick one, or the other, for ETS. Also, not sure why the guy in the video recommends 400 degrees... ETS recognizes 900 degree rotation as 1:1 steering.

TruckersMP Retired Game Moderator

Link to comment
Share on other sites

  • 0
3 hours ago, Maka_paka said:

Benim pc'den 3 gün boyunca uzak olduğum için üzgünüm, Xiolin ve Drawen çözümünü deneyeceğim.

@Drawen , bu ekran görüntüsü için ingilizce çeviri yapabilir miyim lütfen?

Of course I take the official English translation
Gearbox: True (real) automatic
Smart Automatic Gearbox: The high power mode

Logitech G29 driver have you installed on? If you dont from here you can download:
https://support.logitech.com/tr_tr/product/g29-driving-force/downloads

From you news ı am waiting

Link to comment
Share on other sites

  • 0
24 minutes ago, Drawen said:

@Maka_paka Could be a recollection of calibration issues send back to the service. Look at the picture ı had before! Make your arrangements ı hope these will help you please make a comeback...

Logitech Gaming Software Settings:

Adsız.png

Hi @Drawen,

Would you like me to follow your screenshot settings? I am using similar settings as you can see in my video above. 

Do you suggest to send back to seller for replacement? 

Edited by Maka_paka
Missing info
Link to comment
Share on other sites

  • 0
1 hour ago, Maka_paka said:

Hmm... Try removing "Left" and "Right" from the steering and see if it works.

If possible, try another game that supports the racing wheel. If the same issue appears, it's probably a Hardware fault. If it works in other games, then there may be something wring with the game/settings we haven't noticed....

 

~ MrJonton01

Link to comment
Share on other sites

  • 0
35 minutes ago, MrJonton01 [GER] said:

Hmm... Try removing "Left" and "Right" from the steering and see if it works.

If possible, try another game that supports the racing wheel. If the same issue appears, it's probably a Hardware fault. If it works in other games, then there may be something wring with the game/settings we haven't noticed....

 

~ MrJonton01

I have unassigned primary and secondary but unsuccessful. I don't have other game to test. I have already pack and ready to send back tomorrow. 

Link to comment
Share on other sites

  • 0

Hello there @Maka_paka

 

Because this post has been inactive for over 3 days i will be locking and moving it to inactive.

If you require more help you can always message me or another support member.

 

Have a nice day!

 

//locked and moved to inactive

<--> | English / Dutch | <-->

 

 

< Need help with anything? >

< Someone broke the rules? >

< Got banned unfairly? >

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.