Jump to content
  • 0
Sign in to follow this  
Silvrav

Speed limiter inconsistent?

Question

So i found this thread but it was locked :

 

 

I wish to know a bit more about the speed limited.

 

Same road, same truck, with or without cargo:

 

1. Sometimes i can only go 90km/h mark

2. sometimes i have hit the 150km/h mark

 

sometimes I am limited at 90 and trucks come flying past me as I am sure they are hitting the 150km/h mark.

 

is the limiter really that inconsistent? 

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Hello,

If sometimes you are going 90km/h and sometimes 150km/h maybe you are playing Europe 1 server and there is 90km/h limit is been. 
After that maybe you are playing sometimes europe2/3/4, sometimes Europe 1. If you sure you aren't playing Europe 1 server maybe you should change your save file.

Best Regards,

Share this post


Link to post
Share on other sites
  • 0

Heya!

 

I never had those problems with the speed limiter and never had that many customers telling me the limiter is inconsistent; it isn't our work but the work of scs, just to add here.

 

If you can only go 90  there are several possibilities in what causes that issue. One you surely often heard, is that you can only drive 90 km/h if you have got a World of Trucks contract. If you still have got an issue to pass 90 km/h you maybe forgot to deactivate the speed limiter in the gameplay settings or the truckersmp settings.

 

Maybe also if you are driving in the city (at EU2) you are just able to drive 80 km/h.

 

Passing 150 km/h should just happen if you are rolling down a mountain and you shouldn't be able to drive faster than 157. 

 

And if trucks are flying past you, it could be a illusion because 150 is still very fast; or in some cases of course hacking of the other players.

 

I hope you will get your problem solved!

 

Best regards,

NeonLeon

Support

Share this post


Link to post
Share on other sites
  • 0

There are few places in Scandinavia, where the speed limit is lowered to 80 km/h while being on the highway as if you have entered the city. There was similar issue in the past with ATS and the part of the highway in Reno, where you had to drive awfully slow while you could technically reach 60 miles per hour.  The fact that the truck goes past you at 150 km/h in 80 km/h zone, may be caused by the user coasting on the clutch/neutral gear while having cargo on the back, which adds some kinetic energy to the vehicle while being on such unusually placed zone. 

Share this post


Link to post
Share on other sites
  • 0
33 minutes ago, Silvrav said:

 

1. Sometimes i can only go 90km/h mark

2. sometimes i have hit the 150km/h mark

 

 

 

Hello,

 

There has been a updated to wwhere we have a speed limit set to 150km for cars there currently a bug so you have to use  (ctrl & shift)

 

35 minutes ago, Silvrav said:

 

 

 

 

sometimes I am limited at 90 and trucks come flying past me as I am sure they are hitting the 150km/h mark.

 

is the limiter really that inconsistent? 

 

Those users are most likely speed hacking i report those users to TruckersMP because it's not allowed if you see any report them to TruckersMP with evidence but i have to say it quite hard to tell if someone is speed hacking so you have to look very carefull. 

 

 

Regards,

-Arctic Wolf 

Share this post


Link to post
Share on other sites
  • 0

Hello,

 

This may be more than one cause, please check the steps;

 

  • First of all, do not get the job called "External Contract", which limits your speed to 90 km / h.
  • Remove "Speed Limiter" from the TAB Menu.
  • The EU 1 Server limits your speed to 90 km / h.
  • Also, remove the Speed Limit from the game files.
     

Just open C:\Documents\Euro Truck Simulator 2\profiles\ and navigate into the folder of your current profile. Open 'config.cfg' with a Text Editor, search for the line "uset g_use_speed_limiter" and make sure to put a "0" next to it. Then save and close the config-file and check if your speed limiter keeps disabled now

 

Best regards.

Share this post


Link to post
Share on other sites
  • 0

hello

You need to do both of the following:

1-) Disable the speed limiter in your ETS2/ATS settings click here
2-) Disable the speed limiter in the TruckersMP tab menu  click here
3-) You could join a server that has the speed limiter disabled completely after doing steps 1 & 2. (Optional)
4-) Steps 1 & 2 on a server with a speed limiter enabled it will limit you to 110kmh/68mph
5-) Any speed on External Contracts  cannot go more than 90 km/h. 
* To go more than 90 km/h have to remove the limiter and taking those not speed game on External Contracts.

 

Best Regards

Soul Knight:)

Share this post


Link to post
Share on other sites
  • 0
19 hours ago, NeonLeon said:

Heya!

 

I never had those problems with the speed limiter and never had that many customers telling me the limiter is inconsistent; it isn't our work but the work of scs, just to add here.

 

If you can only go 90 you are there are several possibilities in what causes that issue. One you surely often heard, is that you can only drive 90 km/h if you have got a World of Trucks contract. If you still have got an issue to pass 90 km/h you maybe forgot to deactivate the speed limiter in the gameplay settings or the truckersmp settings.

 

Maybe also if you are driving in the city (at EU2) you are just able to drive 80 km/h.

 

Passing 150 km/h should just happen if you are rolling down a mountain and you shouldn't be able to drive faster than 157. 

 

And if trucks are flying past you, it could be a illusion because 150 is still very fast; or in some cases of course hacking be the other players.

 

I hope you will get your problem solved!

 

Best regards,

NeonLeon

Support

Thank you very much and will check if the limit was there for WOT contracts...maybe this is it :)

 

And this is on EU2 for members that asked :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...