Jump to content
  • 0

Question

Hi,

 

I've just got a Logitech G920 and tried playing with it on ETS2 to find that when I take my foot off the accelerator, it automatically brakes. I thought it was my pedals and maybe they were broken so I un-assigned them and tried again. However I'm still having the same issue. It must be in game. Can somebody PLEASE help! I have also attached a clip to show what I mean. At about 0:26 in the video, I take my foot off the accelerator and I'm not touching anything else. 

 

 

Share this post


Link to post
Share on other sites

20 answers to this question

Recommended Posts

  • 1

Can you show both LGS settings and in-game axis bindings in the form of screenshot? I guess you've set the wheel to combine the pedals while the game is set for separated pedals(or vice versa).

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 1

Hello, I play with the same wheel. Try resetting all controls and redoing all your controls. Also, I can not remember which one it is but there should be something under breaking and acceleration that's like Inverted, centered and both or something like that. Change those up until you got it working. Do not worry this is not a problem with your wheel/pedals its in the game settings. Hope this helps :0

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 1

When you go to the Control Settings you can set the mode of the different pedals. Just play a bit with them, you`ll find the right mode pretty fast.

Here is mine, you can try it if you want: 

Spoiler

MMUOxwT.jpg

 

Edited by P??D?T??
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 1

Have you tried setting the initial profiles settings to using a WHEEL instead of Gamepad? I know there's that screen that has that option, I got a Genius Speed Wheel which is basically a gamepad and keyboard thingie, so I chose the gamepad option (I do have accelerator and break foot controls and they work perfectly fine).

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 1

I also use a G920 and i had the same problem when  I started.

Here is a screenshot of my settings, hope it helps.

Only difference i see is our settings for brake dead zone

 

 

G920.png

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

Thanks again for all the suggestions! I've tried all of this and unfortunately I'm still having the problem. My combine pedals is off (it was never on), mt brake deadzone slider is now to the left and has made no difference, and my controller is set as wheel and not gamepad (however I did try it with gamepad and it didn't work). I don't know why it's doing this :(

Share this post


Link to post
Share on other sites
  • 0
Guest Total EDM

Have you tried to reset settings in-game ?

Test other game if same problem still there :)

 

Best Wishes 

Angel_Dark

Share this post


Link to post
Share on other sites
  • 0

Thanks for all the replies and help! I have gotten it fixed thanks to a friend irl. But I appreciate all the suggestions and support. Cheers!

Share this post


Link to post
Share on other sites
  • 0
Guest DeviLee

locked and moved to solved

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...