Jump to content
  • 0

ShadowPlay stops working when Alt-Tabbing


LordBenji
 Share

Question

I started having an issue with my recording software (ShadowPlay) since the 14th of January. At first, it didn't look like there was any issues, because the icon and notifications was displaying correctly. When I finished playing, I noticed that it didn't save any videos at all. The 15th, I realized the problem can be reproduced when I Alt+Tab out of ETS 2, regardless of if it's in single player or multiplayer. When I come back in the game, the ShadowPlay status icon is crossed with a red line. After that, I would basically need to restart the game each time (which would be a big pain in the...)

 

I've tried to uninstall NVIDIA GeForce Experience, restart the computer, and reinstall it. And I still have no luck with it. Recordings work fine, until I Alt+Tab out of the game again. I tried to look up for any solutions online, regarding ShadowPlay stops working, ShadowPlay stops when alt tabbing, and I just can't figure out how to fix it. All I remember that I've done was playing ETS 2 (recording worked just fine the 13th), editing and uploading a video. Last software I've installed was over a week ago. I've also had an OS update but that was before the problem occurred.

 

Could it be the OS itself? I have Windows 10 (family), with Fall Creators Update (that I've had for a while already). It can't be because of my settings, because I haven't changed those at all (except when I did a fresh install of GeForce Experience). I wonder if it's on NVIDIA's side, or on my laptop, I have no clue.

 

If you need more information like the specs, here it is:

-Model: GL552VW

-Processor: Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
-Video Card: NVIDIA GeForce GTX 960M (2GB)
-Video Card #2: Intel(R) HD Graphics 530
-RAM: 16 GB
-Operating System: Microsoft Windows 10 (build 14393), 64-bit

KkdaC1b.png

Link to comment
Share on other sites

Recommended Posts

  • 0

After looking at all errors and warnings, I didn't find any traces of ETS 2 and ShadowPlay.

 

Then I did one of the things that NVIDIA Customer Support asked me to do, which was to revert back to an older version of my NVIDIA Driver. After going through a lengthy process of uninstalling my display driver in safe mode, then installing the older version that I downloaded from NVIDIA website (388.71 for notebook), that seems to do the trick. Weird thing is I still see the red line for maybe one or two seconds... But I tested manual recording and instant replay, going back and forth a few times.

 

Now I hope it stays like that... 

KkdaC1b.png

Link to comment
Share on other sites

  • 0

Hey Benji,

 

Which Nvidia drivers are you using? From Asus or Nvidia directly? 

 

 

I need to get back home to try or duplicate the problem of yours, in the meantime try to uninstall the drivers with DDU.

 

In general the game acts weird when you alt+tab. Also make sure in GeForce Experience(alt+z) at the very bottom privacy settings on.

•Intel® Core™ i7-6850K •Asus ROG Strix X99 Gaming •Asus ROG Strix GeForce GTX 1080 Ti OC 11GB •Corsair Dominator® Platinum Series 32GB DDR4 3000MHz C15 •Samsung 970 PRO NVMe M.2 512GB •Samsung 860 EVO 1TB 
•Corsair HX1000i High-Performance ATX Power Supply •NZXT Kraken X72 •Coolermaster MasterCase H500M
Link to comment
Share on other sites

  • 0

Hello @LordBenji,

 

You can try these steps:

  • Enter Programs from the Control Panel Remove everything related to NVIDIA. Remove ShadowPlay if it exists.
  • Run Driver Sweeper, driver Sweeper will remove NVIDIA drivers.
  • Download and install the latest drivers from NVIDIA site.
When you do all this, the problem will be solved. We must keep programs up to date and new at all times.
Thanks, good game.. :) :90:
Link to comment
Share on other sites

  • 0

Can you confirm that this didn't happen before? Does it happen with other games too?

If it does happen with other games, it was probably a driver update (try rolling back to a previous driver version if you want to test it out). In that case you might want to contact NVidia about it, though I have found them to be not so much helpful with supporting notebooks.

policeceptionsig.thumb.jpg.9ceaf39140d55cb4d0a6821e8ebbe3dd.jpg

Link to comment
Share on other sites

  • 0

Here's an update of the situation.

 

I tried to see if the problem persists in Farming Simulator 17, and it seemed to work just fine. So I went on in the big struggle of completely uninstalling NVIDIA GeForce Experience, then I ran DDU to remove my NVIDIA drivers. Oh lovely black screen after it rebooted (turns out it was just not rendering anything for some reason until I entered my PIN code). Clean install of GeForce Experience, then it downloaded the drivers and did a fresh install.

 

Guess what? The problem still persists when I alt tab out of ETS 2 and go back in. I even tried to change the location of the recording to my "C" drive instead of my "F" drive, and it put a red bar across the status right away after starting the game.

 

I can't deal with this for now. I'll get back to it much later on.

KkdaC1b.png

Link to comment
Share on other sites

  • 0

I believe it's game problem and not Shadowplay problem. The reason is the game gets minimized when you alt+tab so maybe for some reason Shadowplay stops the recoding.

 

Update, so i was recording and i alt+tabbed the game but Shadowplay kept recording. Make sure privacy is on.

 

WDI7XcUXQtKvzQUdpmASiA.png

•Intel® Core™ i7-6850K •Asus ROG Strix X99 Gaming •Asus ROG Strix GeForce GTX 1080 Ti OC 11GB •Corsair Dominator® Platinum Series 32GB DDR4 3000MHz C15 •Samsung 970 PRO NVMe M.2 512GB •Samsung 860 EVO 1TB 
•Corsair HX1000i High-Performance ATX Power Supply •NZXT Kraken X72 •Coolermaster MasterCase H500M
Link to comment
Share on other sites

  • 0

I've only tested Farming Simulator 17 and Euro Truck Simulator 2. I do believe it's a game specific related issue because it doesn't happen at all on the farm simulator. Tried multiple recordings (manual, instant), alt tab, watching back the footage, going back in game. But when I go in ETS 2, it's as soon as I alt tab out and go back in, the red bar appears...

 

I might try what Prototype said, to download from NVIDIA page instead of using GeForce Experience to download the driver version 390.65, which is the latest version... I'm not sure what could be different but if that doesn't work, just forget trying to reinstall drivers. I can't be doing that over and over again in hope of fixing the thing, that's just the pure and true definition of insanity (doing the same thing over and over and expect things to change).

KkdaC1b.png

Link to comment
Share on other sites

  • 0

I uninstalled ETS 2, GeForce Experience, and my NVIDIA drivers (with DDU for the last one), restarted computer, and installed the driver from the website of NVIDIA (clean install), and downloaded the game again, and left the default settings on ShadowPlay (location, all notifications on, etc.)

 

As I mentioned before, doing "alt tab" in my farm game is just fine, I can be away for several minutes, then get back in the game and it would record just fine. But when I open ETS 2 with DirectX x64 (I already tried the first option, just x64), and that I stay in the profile selection menu, it works fine until I "alt tab" out of the game. Then things start to mess up again, like I tried to do manual recording (didn't work), instant replay (did work once surprisingly), "alt tab" out again and went back in, then when I tried instant replay, the icon just put the red line across it.

 

I also found where the CaptureCore.log file was, in case you want to take a look. The file itself is in ProgramData.

https://pastebin.com/1LMfnPd2

KkdaC1b.png

Link to comment
Share on other sites

  • 0

@flybel I always thought that OpenGL and ShadowPlay doesn't work together. I'm not going to try 32-bit because that only works in single player as you probably already know. So that would be irrelevant for my situation.

 

Also, GeForce Experience released an update (3.12.0.84), and I still get that nice red line of death when I "Alt Tab" out of ETS 2 (after freshly starting my laptop). I also tested with American Truck Simulator, and it did the same thing, except I didn't even do "Alt Tab".

 

I've also been told that the fullscreen of those two games from SCS Software are not well made, that it "pauses" the game, hence it might be why it "stops" the recording and fails to "start" again.

KkdaC1b.png

Link to comment
Share on other sites

  • 0

I've had a friend of mine know has some good knowledge about ShadowPlay that went on Teamviewer and tried some stuff (concerning locations, few changes in settings). And after the laptop reboot, it didn't fix it.

 

@flybel I decided to try OpenGL 64-bit... guess what? No red lines woohoo! But the FPS counter and the status icon disappears and wouldn't let me record anymore after doing "Alt Tab". So... It's basically the "same" result.

 

On a side note, I've been told that when I switch to another window (Alt Tab), that ETS 2 doesn't use my GPU (with Optimus on). I tested it and it seems to be true, no sign of GPU usage at all in the Task Manager. So... I think I already asked it, I wonder if changing my options in my BIOS to disable Optimus and just use my GTX 960M would temporarily fix this issue.

KkdaC1b.png

Link to comment
Share on other sites

  • 0

It's not uncommon for a game to pause rendering when you tab out of fullscreen. Unfortunately, ETS does not support borderless window which is very useful in many situations.

As there seems to be no solution, try contacting SCS with your logs. While you're at it, tell them to fix OBS Game Capture too ;)

policeceptionsig.thumb.jpg.9ceaf39140d55cb4d0a6821e8ebbe3dd.jpg

Link to comment
Share on other sites

  • 0

I can't seem to find a way to "disable" my Intel HD graphics. There's nothing in my BIOS concerning which GPU I can use on my laptop.

 

On a side note, I recall posting something after @Istanbullue asked if my issue was resolved (which is not). I wonder why it has been deleted, as I didn't break any rules or went out of topic as far as I know.

KkdaC1b.png

Link to comment
Share on other sites

  • 0

You can't disable the Intel GPU because your screen will not work after..

•Intel® Core™ i7-6850K •Asus ROG Strix X99 Gaming •Asus ROG Strix GeForce GTX 1080 Ti OC 11GB •Corsair Dominator® Platinum Series 32GB DDR4 3000MHz C15 •Samsung 970 PRO NVMe M.2 512GB •Samsung 860 EVO 1TB 
•Corsair HX1000i High-Performance ATX Power Supply •NZXT Kraken X72 •Coolermaster MasterCase H500M
Link to comment
Share on other sites

  • 0

@flybel I've always set in my NVIDIA control panel to use high performance NVIDIA GPU, and even did it on global settings, and it didn't change anything about the recording after doing "alt tab" out of the game.

 

Here's the thing, I've had this laptop for quite a while, and despite having a few recording issues in the past that I could fix by rebooting my laptop or doing some updates, I've never ever had anything like this before. I really don't understand how it just suddenly happens, like nothing considerable even happened during the day it started messing up (as far as I know).

 

I've been recording since July 2016 (maybe a bit earlier) on ETS 2 with this laptop, and I'm confused about what could be the source of the issue, why would it fail to start recording again after changing the focus...

KkdaC1b.png

Link to comment
Share on other sites

  • 0
15 hours ago, LordBenji said:

I've always set in my NVIDIA control panel to use high performance NVIDIA GPU, and even did it on global settings, and it didn't change anything about the recording after doing "alt tab" out of the game.

As I said before,

On 21.1.2018 at 11:37 AM, flybel said:

I doubt that this is the issue

 

 

15 hours ago, LordBenji said:

it just suddenly happens, like nothing considerable even happened during the day it started messing up

That's Windows... stuff like this happens.

 

15 hours ago, LordBenji said:

I'm confused about what could be the source of the issue, why would it fail to start recording again after changing the focus...

ShadowPlay is rather hard to troubleshoot, especially on a notebook (I've had my unresolvable issues too where others had no problem with ShadowPlay and Multi Theft Auto San Andreas). That's why you need to contact SCS and/or NVidia, because we may not be able to recreate or solve the issue here.

policeceptionsig.thumb.jpg.9ceaf39140d55cb4d0a6821e8ebbe3dd.jpg

Link to comment
Share on other sites

  • 0

I submitted a ticket to NVIDIA help desk. For now, the only "solution" is to avoid doing "Alt + Tab" during game play on ETS 2, or else I'd have to reboot my laptop.

 

On another note, I haven't got any useful replies on the SCS Software forum. One person suggested to toggle privacy control, but I don't have that setting as I'm using a laptop. There is nothing else after "Notifications" in the list of settings.

KkdaC1b.png

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.