Jump to content
  • 0

ShadowPlay stops working when Alt-Tabbing


LordBenji
 Share

Question

I started having an issue with my recording software (ShadowPlay) since the 14th of January. At first, it didn't look like there was any issues, because the icon and notifications was displaying correctly. When I finished playing, I noticed that it didn't save any videos at all. The 15th, I realized the problem can be reproduced when I Alt+Tab out of ETS 2, regardless of if it's in single player or multiplayer. When I come back in the game, the ShadowPlay status icon is crossed with a red line. After that, I would basically need to restart the game each time (which would be a big pain in the...)

 

I've tried to uninstall NVIDIA GeForce Experience, restart the computer, and reinstall it. And I still have no luck with it. Recordings work fine, until I Alt+Tab out of the game again. I tried to look up for any solutions online, regarding ShadowPlay stops working, ShadowPlay stops when alt tabbing, and I just can't figure out how to fix it. All I remember that I've done was playing ETS 2 (recording worked just fine the 13th), editing and uploading a video. Last software I've installed was over a week ago. I've also had an OS update but that was before the problem occurred.

 

Could it be the OS itself? I have Windows 10 (family), with Fall Creators Update (that I've had for a while already). It can't be because of my settings, because I haven't changed those at all (except when I did a fresh install of GeForce Experience). I wonder if it's on NVIDIA's side, or on my laptop, I have no clue.

 

If you need more information like the specs, here it is:

-Model: GL552VW

-Processor: Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
-Video Card: NVIDIA GeForce GTX 960M (2GB)
-Video Card #2: Intel(R) HD Graphics 530
-RAM: 16 GB
-Operating System: Microsoft Windows 10 (build 14393), 64-bit

KkdaC1b.png

Link to comment
Share on other sites

Recommended Posts

  • 0

@Smalley I'm actually aware that this issue is only related to ShadowPlay. I tried OBS recording software and it does work (but very choppy recording). Also I'd rather avoid anything that will upload or stream videos, as the upload speed is incredibly slow. Heck I'm slower than 77% of Canadians...

Spoiler

7004277471.png

 

@walidsadki98 I think you've misread the requirements for ShadowPlay. Or else, why would it work perfectly fine in other games? With an usually smooth recording, even in ETS 2, which I've been doing for quite some time.

Here's what it states: GTX (for PC) 600 or better, or GTX (for notebook) 660M, [...], 700M or better. The GTX 960M is more recent and better than that, as far as I know.

 

Also on a side note, I've submitted a help form at NVIDIA customer support. The tech support asked me a few things like msinfo32 and NVIDIA system information, along with a screenshot of that red line.

KkdaC1b.png

Link to comment
Share on other sites

  • 0

It doesn't make any sense 

 

7PQI5NRtTfmp7sezQs14bg.png

nsGEo_jrQsueHSqqfAB1ZQ.png

•Intel® Core™ i7-6850K •Asus ROG Strix X99 Gaming •Asus ROG Strix GeForce GTX 1080 Ti OC 11GB •Corsair Dominator® Platinum Series 32GB DDR4 3000MHz C15 •Samsung 970 PRO NVMe M.2 512GB •Samsung 860 EVO 1TB 
•Corsair HX1000i High-Performance ATX Power Supply •NZXT Kraken X72 •Coolermaster MasterCase H500M
Link to comment
Share on other sites

  • 0

After following some of the steps suggested by the customer support of NVIDIA, *deep sighs*, sadly it doesn't fix my issue of the red line of death.

 

Some of those includes making sure I have the latest version of GeForce Experience (duh!), that I have enough storage space (am I lacking space with 629 GB on my C and 1.53 TB on my F?), and creating a folder which isn't located in Users (I made one there: "C:/Video_temp"), and one tiny thing I almost missed was the "Allow desktop capture" in the HUD layout, which does not show up when having a gaming notebook...

 

Also, he mentioned to follow some steps which includes enabling Experimental Features, deleting two JSON share files in Program files x86, NVIDIA Corp, so on, open and close GeForce Experience, reinstall it, reopen it, restart laptop, then check if the issue is still there. Which it is! I mean as soon as I change the focus out of Euro Truck Simulator 2 for a couple of seconds (for example watching the video recorded just before changing focus), then when I come back... red line of death.

KkdaC1b.png

Link to comment
Share on other sites

  • 0

From what you are saying it seems like there is no fix for that..

 

Something that nobody has suggested to you is to use an older version of GeForce Experience.

 

https://forums.geforce.com/default/topic/973257/geforce-experience/how-to-downgrade-geforce-experience-back-to-v2-11-4-0-and-block-the-update/

 

Link for download because the link is dead inside that topic https://forums.videocardz.com/topic/1495-nvidia-geforce-experience-21140/

•Intel® Core™ i7-6850K •Asus ROG Strix X99 Gaming •Asus ROG Strix GeForce GTX 1080 Ti OC 11GB •Corsair Dominator® Platinum Series 32GB DDR4 3000MHz C15 •Samsung 970 PRO NVMe M.2 512GB •Samsung 860 EVO 1TB 
•Corsair HX1000i High-Performance ATX Power Supply •NZXT Kraken X72 •Coolermaster MasterCase H500M
Link to comment
Share on other sites

  • 0
On 1/16/2018 at 9:49 PM, LordBenji said:

I've only tested Farming Simulator 17 and Euro Truck Simulator 2. I do believe it's a game specific related issue because it doesn't happen at all on the farm simulator. Tried multiple recordings (manual, instant), alt tab, watching back the footage, going back in game. But when I go in ETS 2, it's as soon as I alt tab out and go back in, the red bar appears...

 

I might try what Prototype said, to download from NVIDIA page instead of using GeForce Experience to download the driver version 390.65, which is the latest version... I'm not sure what could be different but if that doesn't work, just forget trying to reinstall drivers. I can't be doing that over and over again in hope of fixing the thing, that's just the pure and true definition of insanity (doing the same thing over and over and expect things to change).

 

 

I'm an advanced IT student, and happen to be very experienced in Nvidia,

 

 

I strongly recommend you to remain using the Geforce Exerience, since they update the graphics card whenever a new update comes out (it does prevent corruption in engine failure with graphical programs)

 

 

Secondly, make sure that (if you're not on a laptop) your computer has disabled the Intel "graphics card" since this should have automatically disabled by your system (motherboard) as it is a strict policy that the system is not allowed to use both hardware pieces at the same time (i could explain it to you, but that would mean i'd own the website in size of explanation).

 

 

Even though this might seem odd to you, changes are 90% that the issue lays with ETS2 creating a session that "disallows" the Geforce Experience into working properly.

 

 

 

Try reinstalling All required software, drivers, and make sure to check for any drivers that might make you feel like they are the cause of it (don't worry, uninstalling such won't harm a soul)

 

 

And last, if non of the above works, make sure to press start key + R, type eventvwr, go to applications & Services Log, and check for any errors related to Nvidia or ETS2

 

 

Goodluck, and if any questions make sure to reply to this post.

'Ride or Die'

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.