Jump to content
  • 0
Sign in to follow this  
buLLet

Game freezes my computer

Question

So this happened to me a few times - sometimes when I'm in a city (it never happened outside of them, but could be coincidence) the game lags a little (which happens everytime a player streams into my game) but right then it freezes.

 

I tried alt-tabbing out of it, ctrl alt delete etc. but nothing helps, so the only solution I have right now, is to turn off the computer which is quite annoying...

 

I also checked the game crash log, but it didn't leave a single log of that crash. I'll post here a crash log I got because of a different crash so you can at least check my system configuration (or whatever else is there :D):

 

http://pastebin.com/37gfepZA

 

Also this has never happened to me while in SP.

 

Thanks for the help.

 

 

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

Update driver for grafic card. Change your setting in MP. Disable low detail in grafic setting. Your grafic card is ready for full detail.

 

And stop all others aplication. Skype,MSN, etc.You have available verry small memory.

Share this post


Link to post
Share on other sites
  • 0

This happens sometimes by me too.It freezes and then after 30 Sekonds-1 Minute it loads again,This happens by me when a City hits 50 Players (I Think).But sometimes when the game frezzes i needed to restart the PC too.

Share this post


Link to post
Share on other sites
  • 0

Update driver for grafic card. Change your setting in MP. Disable low detail in grafic setting. Your grafic card is ready for full detail.

 

And stop all others aplication. Skype,MSN, etc.You have available verry small memory.

 
Thanks. I updated the driver. But I'm not so sure about the graphics settings. I changed every MP setting to the lowest possible except some which are apparently experimental (and caused me some crashes), because before those settings, it was lagging as hell, mainly in cities.
 
Also by that graphic detail, do you mean textures or smoothing of objects (in MP settings) or something else?
 
Here's my MP settings config file:

Share this post


Link to post
Share on other sites
  • 0

Here is my MP setting and my PC configuration. Graphic setting in game is set as full. Only color corection is off. Not for performance but better colors.

 

   "generals" : {
      "development_logging" : true,
      "drivers_animations" : true,
      "fast_assets_loading" : true,
      "season_effects" : false,
      "smoothing_distance" : 400,
      "use_lods" : false
   },
   "graphics" : {
      "additional_lights" : true,
      "avatars" : false,
      "draw_distance" : 400,
      "draw_drivers" : true,
      "dynamic_shadows" : true,
      "fake_shadows" : true,
      "force_low_details" : false,
      "headlights" : true
   },
   "mods" : {
      "winter_mod" : false
   },
   "sounds" : {
      "engine" : true,
      "gearbox" : true,
      "horn" : true,
      "lift_axle" : false,
      "master_volume" : 97,
      "music_volume" : 97,
      "reversing" : true,
      "sound_effects" : true,
      "sound_effects_volume" : 97

 

PC

System version: Windows 7 Ultimate, Service Pack 1
System Type: x64
Processor: AMD Phenom ™ II X4 840 Processor 3.20 GHz
System Memory: 4 GB
Graphics card: nVidia GeForce 9800GT

 

 

Change "force_low_details" : false,

              "use_lods" : false

 

install DirectX 11

Download MalwareBytes and check your PC for malvare.

Run only ETS2MP and Steam. All others program and aplication turn off.

Share this post


Link to post
Share on other sites
  • 0

RayRay5

Take a good look at my configuration.
I do not have any problems. When all will work the game as I will not need us. And this session will be able to cancel.
Look at the minimum requirements of the game. Multiplayer working only in x86 version,i.e. in 32bit. 32bit system only uses 3.2 GB of RAM. Why should therefore be 4 GB few, i not understand.
Moreover, the system still uses virtual memory. That's another 4 GB.

Share this post


Link to post
Share on other sites
  • 0

First: Where are the Instructions/Data for the computer mainly stored? At the RA-memory. If there is barely no more free RA-memory the Instructions/Data get stored in the pagefile on harddrive which is slow. Slow reading of harddrive causes longer transmission times of the data. This causes the processor to wait and therefore affects the performance.

 

Second: I was referring to (3d-)Benchmarks. And they exist for a good reason. And both cpu and gpu had bad values

 

Third: Having 4GB is one thing, but what really matters is the configuration and the frequency and the Bandwidth. A configuration with 1 4GB module with frequency f is slower than 2 2GB modules with the same frequency since you could access both 2GB modules "parallel" and therefore gain some speed. Same counts for the bandwidth.

 

a8 and 4Gb, it is not a bottleneck, a bottleneck is AMD Athlon which cost €70, with a GTX990.. (Example)

Well on the benchmark-table I've found multiple athlon cpus which have a higher performance than the a6. But you're right it's not a real bottleneck, but for the software the hardware is kind of a bottleneck.

Share this post


Link to post
Share on other sites
  • 0

RayRay5

That's not true, even if the game does not use all the RAM uses virtual memory. Same with Windows. Default has allocated 2 GB of 4GB for the system, next 2GB is for others aplication and programs. If you want to see what Microsoft says I can give the link. I think it's pointless to argue. We are trying to help.

okay, lets stop arguing.

 

@OP: did the error occur again?

Share this post


Link to post
Share on other sites
  • 0

okay, lets stop arguing.

 

@OP: did the error occur again?

 

Just once, but it was only because some other driver crashed/lagged into me and my truck was shot straight into the sky because of that collision... D: it was also near Rotterdam, so you know.. a lot of trucks. But apart from this, it didn't happen.

 

What other stuff are you running on background? (every time it changes somg, my game gets minor lagpike)

When that crash occurred, just skype and chrome with one tab open (and steam of course). Actually, the game runs well for me, It lags a little only when other player's trucks appear/load in my game.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...