Jump to content
  • 0

ETS2 and OBS


Guest Balina

Question

Guest Balina

Hi, i have been trying to stream ETS2 on StreamlabsOBS but i couldn't  manage to do it.

 

What i have done so far:

  • ETS2 Launch options as OpenGL, DirectX 9, Normal 64bit.
  • OBS Classic, Streamlabs OBS
  • Disabled Firewall[Kaspersky],
  • Uninstalled-reinstalled OBS
  • Updated my drivers including windows 10 updates
  • Cleared my obs caches,cookies many many times, created new scenes, deleted old screnes, and re-created new scenes again nothing changed

 

Thanks already..

Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

More detail for the question would help but I am guessing your OBS is not detecting the game? If so, the correct way to make your game appear in OBS is by clicking the "+" on the Scene box and select Game Capture, or Display Capture if you want your desktop to be recorded also.

 

Kind Regards,

~TanFlicks

Link to post
Share on other sites
  • 0
Guest Balina
  • I get a blackscreen when i choose game capture, and i have also tried other capture styles, too.
  • I am trying to stream on Twitch, yes a connection between OBS and Twitch have been made. There is no error message, and yes i did put the correct streaming key.

 

OBS Picture

Edited by Balina
I have added a screen shot from my OBS
Link to post
Share on other sites
  • 0

Hello!

 

Welcome to TMP's Forums!

 

Might be worth trying to run ETS2 in windowed mode which can be found under graphics settings. This should mean it pops up better with the windows task bar at the bottom.

 

Hope this helps,

 

George

Kind

Regards,

Whitelodge

 

 

spacer.png | wxsUkv6.png

 

Event Request | Event Calendar | Feedback | Events

 

Link to post
Share on other sites
  • 0
Guest WentworthHFD

Hello @Balina,

 

do you have laptop or PC? If you have laptop, that is the problem why you can't use game recording and you are getting black screen. If you are using PC, try to disable your anti-virus and makse sure you have installed GPU drivers updated and DirectX.

If you only have a black screen, it may be because OBS doesn't detect your game, if it is set to automatic detection. I did had this problem, but it would normally return to normal about a minute later. How long have you waited out?

Try this: Go to OBS and select your prefered Scene, then at the right, right click "Game Capture" and then "Properties". On Mode, select ETS2's executable (also, make sure you do so while ETS2 is running).  If everything goes right, it should start capturing directly from your game almost immediately, if not, wait about a minute or so. I hope this helps!

 

Best Regards,

WentworthHFD

Link to post
Share on other sites
  • 0
Guest Balina

Ok, thanks you all for trying to help me, but i found the solution and the solution is, you switch the compatibility mode to windows 8.(ets2, ets2mp launcher, steam, streamlabsobs, i run these four at windows 8)

Link to post
Share on other sites
  • 0

Problem solved. Thanks to everyone.

 

//locked and moved to Solved Topics

Sincerely,
AdaBey

TruckersMP Game Moderator

Support of the Year 2018

 

Official Rules Official Turkish Rules | Support Ticket | Steam How to become a Game Moderator?

 

¯\_(ツ)_/¯

SometimesTheUglyTruthCanBeBeautiful

Nothing last forever.

 

 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...