Jump to content
  • 0

Question

Hello, I have started playing Euro Truck a week ago and started playing Multi Player 2 days ago.

 

I have no problems playing Single Player over 100 fps stable but in Multi Player my game freezes for 0.5 secs whenever i get someone at "Players near to you" tab. Tried lots of things none of them solved my problem. There is a ingame video to show you what is happening link below. I am using wi-fi not ethernet but I am not sure if thats the problem. I have 100 mbts download and 5 mbts upload. Before you ask my drivers are up to date and i will share my computers specs down below. My computer using all 8 cores and not on power save mode. Graphics doesn't matter it happens even in lowest resolution. I have this stuttering propblem only ETS2 MP right now but i had stuttering on CS:GO before they relased panorama update, that fixed it.

 

3 Year Old Gaming Laptop ASUS G550JK

OS: Windows 10 Home Single Language 64-bit (6.2, Build 9200)

CPU: Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz

GPU1: GeForce GTX 850M on GM107-A GPU

GPU2: Intel(R) HD Graphics 4600

RAM: 8GB

 

Ingame footage: https://mega.nz/#!Zg4iXSwZ!f6qx_cchxTajkzzqwIBk4UlEJG935nRXiDKreDh_2qE

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Hello! 
Try to re-install TruckersMP Launcher and ETS2. 
Also try to turn off driver's animation and another items like animated flags in multiplayer settings (In Tab).

You can try to start singleplayer ETS2 with DirectX instead OpenGL or conversely.

Can you send screenshot with your graphics settings (in-game)?

 

Regards,

LuckyOne.

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hello :) 

Try these

1. Locate and Secure your Profiles, Copy them to a seperate Folder.

ATS: http://prntscr.com/f7ofiu

ETS: http://prntscr.com/f6bney

2. Then de-install ATS/ETS2 via Steam and de- install TruckersMP.

3. Restart your PC.

4. Then start searching for all old Folders of TruckersMP and ATS/ETS2 and Delete them. A RegCleaner Software will be helpfull. Sometimes there are "Dumb" Folders/Paths to ATS/ETS2, that were created by the TruckersMP Launcher. 

http://prntscr.com/hommq6 

http://prntscr.com/hommzm 

http://prntscr.com/homn7x

5. When u deleted all Folders, Restart ur PC Again.

6. Log In to Steam-->Rightclick on Steam--->Settings-->Download-->Steam Library Folders-->Add Library Folder---->Choose another Partition or Hdd and mark it as Default Library. 

http://prntscr.com/homntm 

http://prntscr.com/homozx

7. After that Procedure, Re- Install ATS/ETS2 via Steam into the new Library, make sure you installing this Version.

ETS: http://prntscr.com/f7nmne

ATS: http://prntscr.com/f85fz

important: Check TruckersMP for the actual Versions of the Game, they can be different!!

8. Start the Game in Single Player and check the Version. Create a new Profile, but do not Drive. Close the Game.

9. Search with Windows File Explorer the Path to the ETS/ATS Installation. Keep this Path in Mind.

After that, download the actual Version of TruckersMP, unpack it to a seperate Folder. Install it from this Folder as Administrator.

Make sure that you having the right Path to the Games when you Installing TruckersMP.

You have to check them manually, do not let the Launcher Auto searching for them.

10. After the Installation start the Launcher as Administrator and let him finishing his Downloads. Then start the Multiplayer. If you can Play, close the Game and insert your old Game Pofiles.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hi there,

Try this

  • Verify game cache
  • Delete garages, drivers.
  • Load other save game.
  • Make new profile.
  • Make sure you have the latest .Net Framework (4.7) & DirectX & Microsoft Visual C++ 2015 and use CCleaner to remove temporary files and obsolete registry paths.
  • Update your graphic card driver.
  • Pull down your graphics settings.
  • Take care not to play in busy areas.
  • If your Game is freezing for a long period it is because the mod Is attempting to its game time with the core game time. (SP & MP times are quite different)!
  • Go in company manager (this may be a pain) and fire all of your drivers first. 
  • Save your progress then completely close the game
  • Go into your Euro Truck Simulator 2 documents folders and select/highlight the your last profile (look at last modified) then with it highlighted hit the delete button.  (Again I know it could be a pain)

g8a452.jpg9oy94Q.jpg

 

And read these topics:

 

Share this post


Link to post
Share on other sites
  • 0

Thanks for responses! 

I have already did these:

  • Verified game cache

  • Only 1 garage, 1 truck, no hired drivers 

  • Load other save games

  • Made new profiles

  • All drivers are up to date 

  • Used CCleaner

  • No antivirus program

  • Turned off Windows defender

  • Update your graphic card driver.

  • Pull down your graphics settings.

  • Reinstall TruckersMP

  • Start as admin TruckersMP

  • Start as admin ETS

  • Started with both DirectX64 and OpenGL

  • Disabled Fullscreen Improvements

  • My Laptop using all 8 cores

  • Not on power saving mode

  • Used Game Booster

  • Trying to avoid high populated cities but this happens on highway as well.

 

What I haven't done yet is reinstalling ETS2. I will do it now and give you guys update! And I got an ethernet cable borrowed from friend, will use that as well.

 

1.PNG

2.PNG

3.PNG

4.PNG

Edited by aGift4u
typo

Share this post


Link to post
Share on other sites
  • 0
48 minutes ago, [LKW Tr.] Tidders [LET] said:

I had a problem like this when my pc did not give the game enough ram to the  game so make sure that you have not accidentally limited the ram to 2gb or something like that.

 

Thanks for your response but I don't know how to give enough ram. Also in the video I shared at post, It says using 4500 ram. That should be enough right?

1.PNG

Share this post


Link to post
Share on other sites
  • 0

Hey!

Try turn on V-Sync, it should help.

 

Regards,
LuckyOne.

 

Share this post


Link to post
Share on other sites
  • 0

Heya!

 

Game performance problems, such as slow frame rates or occasional slow frames, can be caused by bugs or inefficient coding in the games, or by hardware Problems. Hardware problems don’t evenly affect all games, so even if just one game is showing problems it is worth checking your Hardware.

 

CPU Slowdowns

In some situations your CPU may slow down while you are playing a game. This can be caused by overheating, or it can be caused by attempts to conserve battery power. Sudden slowdowns – where the game is running fine and then the frame rate drops quite suddenly – are sometimes caused by these CPU slowdowns. If your frame rate doesn’t improve when you lower the game’s resolution then the game’s performance is probably limited by CPU performance and these diagnostic steps may be appropriate. There are also some third-party tools that can be used to diagnose these problems.
CPU-Z  (http://www.cpuid.com/softwares/cpu-z.html) is a free tool that shows your CPU’s speed in real-time. If you run the game in a window and run CPU-Z beside it then you can monitor the CPU speed and see if it is dropping when the game slows down. Unfortunately, some types of thermal throttling are not correctly measured by CPU-Z. Since the main cause of CPU slowdowns is overheating, monitoring your CPU temperature is another way to diagnose what is happening. Real Temp (http://www.techpowerup.com/realtemp/) supports Intel processors only. Core Temp (http://alcpu.com/CoreTemp/) supports both Intel and AMD processors. Note that the maximum temperature allowed may vary considerably between manufacturers and models. See http://www.alcpu.com/forums/viewtopic.php?f=63&t=892 for some discussion of this. Temperature monitoring will generally never show your CPU above its limits because modern CPUs slow down to avoid overheating. Anytime that the CPU temperature approaches the limits you should treat that as a likely problem. If your CPU is overheating then it usually means that the cooling system is not working correctly. This can be caused by poor design (too small a heat sink, or poor ventilation), by poor placement (a PC in a stereo cabinet may not get enough fresh air), or by dust accumulating on the vents, fans, and heat sinks. Make sure that your PC is getting enough cool room air, be careful that vents aren’t being blocked by carpet, and perhaps open up your PC and remove clumps of dust, or blow them away with compressed air

 

Insufficient memory

If your system runs low on memory then your game or Steam might start being swapped to disk which can cause repeated frame rate hitches. In addition, if Windows doesn’t have many GB of free RAM then it cannot cache frequently used files, which can make level loading take far longer. As a rule of thumb you should try to ensure that the Available Memory  shown in the Performance tab of Task Manager shows at least 1,000 MB available. Having 2,000 MB or more available is safer. If Available memory goes below about 800 MB then Windows will start writing data to disk in order to make more memory available. Therefore, Available memory will rarely be seen to be below 800 MB, and the safe thing to do is to ensure that it never gets too close to this point. There truly is no such thing as too much memory. If you have 8+ GB of memory then Windows will cache many files, and level loads and game relaunches will be fast and fluid.

 

Best regards,

NeonLeon

TruckersMP Support

  • Woah! 2

Share this post


Link to post
Share on other sites
  • 0

HELLO

as you said

2 hours ago, aGift4u said:

I have no problems playing Single Player over 100 fps stable but in Multi Player my game freezes for 0.5 secs whenever i get someone at "Players near to you" tab

you should also read this topics to solve your problem

 

Best Regards

Soul Knight:)

Share this post


Link to post
Share on other sites
  • 0

hello make sure you only have open truckers mp dont have anything open also try updating your drivers i had this struggle when i started playing on my new laptop

HP omen 

Core i7 

4gb ram

nvidia 1050 ti

i updated drivers and it worked like a dream

Share this post


Link to post
Share on other sites
  • 0

Hi again. Thank you all for your responses however;

 

3 hours ago, [ETS2MCG] Kien Giang said:

Hello :) 

Try these

I have reinstalled everything as you said. Unfortunately nothing has changed.

 

2 hours ago, Jxsh_y said:

^ Well, if you have 8gb RAM, you should have plenty more to feed ETS. 

I recommend you try this: https://fossbytes.com/how-to-fix-high-ram-and-cpu-usage-of-windows-10-system-ntoskrnl-exe-process/

After completed, you should have more RAM to feed ETS.

If that did not work, have to considered the problem being your internet?

It is using 4900-5000 ingame but I think that is what ETS2 is asking for and there is plenty more spare waiting. Added pic of ram usage while playing. Anyway I did everything in that link you recommened but it still uses 5000.

Used ethernet cable and nothing changed either. (Btw I have low ping: 50ms) 

 

1 hour ago, LuckyOne said:

 

Try turn on V-Sync, it should help.

 

 

Turned it on. Problem still occurs.

 

1 hour ago, NeonLeon said:

CPU Slowdowns

As showed in video, It is not even using my CPU at high temp. 

 

57 minutes ago, P1NK said:

i updated drivers and it worked like a dream

Wish that happened to me :(  It says all drivers are up to date.

 

1 hour ago, Soul Knight said:

you should also read this topics to solve your problem

I have read them, didn't help :( 

 

 

1.PNG

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, aGift4u said:

 

Thanks for your response but I don't know how to give enough ram. Also in the video I shared at post, It says using 4500 ram. That should be enough right?

1.PNG

looking at the stats there it seems to be some problem that is not related to your specs so uninstall tmp but make sure to delete the tmp files (not the ets2 one cause you will loose all of your stuff) because sometimes when a program is uninstalled it can sometimes leave the files and when you re install it it will use to files that are already present. It is unlikely that this will work but it seems that you have tried pretty much every other option.

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, [LKW Tr.] Tidders [LET] said:

looking at the stats there it seems to be some problem that is not related to your specs

That is what i am thinking as well. I completly uninstalled everything and reinstalled. Nothing :(

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, TFM DJ ccowie said:

Hi there,

Has any of these replies helped you?

~ccowie

Nope, none of them fixed my problem sadly.

Share this post


Link to post
Share on other sites
  • 0

Hi,

 

You mentioned that you get freezes when someone comes near you and above you posted a picture of your CPU/GPU/RAM usage and I'm guessing you took this screenshot when your game was stable, but during the freeze, does anything spike? (Such as CPU/GPU usage)

Share this post


Link to post
Share on other sites
  • 0
13 hours ago, Kubuntu said:

Hi,

 

You mentioned that you get freezes when someone comes near you and above you posted a picture of your CPU/GPU/RAM usage and I'm guessing you took this screenshot when your game was stable, but during the freeze, does anything spike? (Such as CPU/GPU usage)

Hello, I have shared a ingame video where you can see whenever i get someone at "Players near to you" tab game freezes like half a second. In that video you can see cpu, gpu, ram and mem usage. As far as i saw only thing changes is GPU usage gets to %0. Feel free to check to video, maybe I am missing something. https://mega.nz/#!Zg4iXSwZ!f6qx_cchxTajkzzqwIBk4UlEJG935nRXiDKreDh_2qE

 

36 minutes ago, Frosty. said:

Have you tried opening ETS2MP, and then shutting down everything in the background? Especially browsers, they take up a lot of RAM.

Yeah I did and there is plenty more free RAM ETS2 can use if it wants. 

 

 

Guys please check the video I might be missing something: https://mega.nz/#!Zg4iXSwZ!f6qx_cchxTajkzzqwIBk4UlEJG935nRXiDKreDh_2qE

Share this post


Link to post
Share on other sites
  • 0
Guest -Andreas- [Chef][GER,ENG]

Disabling Season Effects and Winter Mod may help gain some FPS

Disabling Cabin Accessories and Flags may also help for low-end PCs. *Update* Using the 2 outside flags on your vehicle can drop you 30 frames and if you use the small flags in the cabin can drop you up to 50 frames!!!

Owning DLC's might help a bit with low FPS aswell in crowded areas since the game instantly loads the original skin and doesn't replace it with a random color.

Installing the game into an SSD helps with game loading and auto-save freeze.

Always install the latest GPU drivers. Before you install the new drivers remove the old ones with Display Driver Uninstaller (DDU). If you are on a desktop download the drivers from AMD or Nvidia. If you are using a laptop you should download the drivers from the manufacturer!

Keep trucks and drivers to the minimum, the more drivers, and trucks you have the more lag will cause you when the game auto-saves or when you teleport. It also helps to save quicker when you use PrtScn (quick save).

A max amount of 15 drivers in 3 garages is recommended. Other garages can be bought but do not assign any AI drivers to them.

Changing you save format for the purposes of saving editing will cause auto-save lag issues on large profiles and slower systems. To remedy this, changing the `g_save_format` value to the default of 0 will drastically reduce your profile's auto-save time. Though with the default save format, you cannot make modifications to your save file, such as adding customs jobs using Virtual Expeditor.

Always but always make sure you run the game on DirectX and not OpenCL. Running the game on OpenCL will cut your FPS to half or even cause you game crash. If you are not sure if you run MP in DirectX run the game once in SP by Choosing "Launch ETS2 DirectX (64-bit)". 

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...