Question

Hi,

whenever I play MP on ATS or ETS2, usually it'll run fine and then suddenly I'll start lagging like crazy. 

Not fps wise- I mean when I'm not even near someone, somehow they'll curse at me in chat telling to move because I'm apparently blocking their path on THEIR screen only. 

The distances will also get really big and their name still appears on the players near you menu even though on my screen I'm far far away from them. 

 

In several instances I've had people report me because on their screen I'm stopped in the middle of the street. I noticed I can't use the chat when this is happening- it just doesn't work, so I have no way of telling them that it's just lag and I'm not actually near them on my screen. 

 

I have fiber internet so I've been seriously doubting that being part of the problem... but if there is a problem on my end please help me fix it! 

I've already re-downloaded TruckersMP (not that it would fix anything) 

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

Most likely problem is from your internet, if you say your screen isn't freezing. Or from your pc specs, try to set them lower. Reinstalling the MP mod will not solve your problem. I recommend you to contact your internet provider.

Share this post


Link to post
Share on other sites
  • 0

Depending on your computer specifications is how the game will run, believe it or not I have the same issue but mine is a Intel Pentium T4500, 3GB ram, and a Intel HD graphics 4000. Also try lowering resolutions (Pixels), Restarting your Wi-Fi modem and restarting your PC. If this doesn't help I'm not sure what else to try other then contacting a developer and asking them to see what they can do from their end. :-)

Share this post


Link to post
Share on other sites
  • 0

@sko0923

I've tried all of the above and it still doesn't seem to be resolved. The only thing that "fixes" the problem is if I restart the game, but then 5 minutes in it'll happen again. 

Not sure what else to do.. :/

Share this post


Link to post
Share on other sites
  • 0

Hi @Nukeshi,

 

Would you mind doing a speed test here: www.speedtest.net and sharing your results here? Just so that I can make sure that it is not your internet connection.

 

Regards,

sko0923. 

Share this post


Link to post
Share on other sites
  • 0

Hi @Nukeshi,

 

It appears that the issue is likely your internet connection. Do you have problems playing any other online games? While your ping and uplaod speed is excellent, your download speed looks to be extremely low. I would recommend at least 5Mb/s download speed, or around 30Mbps to play online games, if you are the only one using the internet. 

 

Regards,

sko0923.

Share this post


Link to post
Share on other sites
  • 0

 

Let your modem read out, it seems that you have a malfunction.
You can also watch your values in your moden at Down and Upstream.

Downstream and upstream power levels are important when determining if the cable line that is connected to your cable modem or modem router is receiving sufficient power.
Good Downstream power levels are within -7 to +7 dBmV. Good Upstream power levels are within 38-48 dBmV.
Your provider can also read out your modem and see if there is a problem with your internet.
Your down is far too low to be able to play online, especially ETS2MP.
Have you also try an other cable to test if this is better.

Share this post


Link to post
Share on other sites
  • 0

@sko0923

I just switched to our other wifi network (or whatever you call it- i'm bad with this stuff) because it seems to be more reliable... my upload/download speed is fantastic now, but I noticed when trying to connect to multiplayer, it never actually connects. It keeps loading and loading, and then it will say "connection with server has been broken, you will be automatically reconnected and starts all over again. I do sometimes get connected to the server, but it can take up to 30-45 minutes even when the queue is short, and then even with good internet speed it still lags. 

Any ideas? 

 

 

 

6682223136.png

 

Share this post


Link to post
Share on other sites
  • 0

You said it yourself. Wi-Fi network. Wi-Fi for gaming it's just terrible, it can cause you a lot of problems out of nowhere. Disconnects, unstable connection, lag. Ethernet all the way. If you have 2-3 walls before the router itself don't expect for a solution.

 

Here i explain some stuff about connection in general and also about Wi-Fi.

 

https://forum.truckersmp.com/index.php?/topic/44581-troubleshoot-support-performance-guide/#3_2

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.