Jump to content
Wolfseye

Logitech G920 + ATS = Brakes permanent

Recommended Posts

Hi guys,

i just got my Logitech G920 i ordered. Installed all the stuff, but in ATS i have something weird. When I choose the Wheel, in the BRAKE AXXIS section, the brake seems to be permanentely pressed. That organge bar is fully in, while in ACCELERATION AXXIS its only glowing orange when I press the gas pedal. Whats going on here ? Anyone else had that issue ?

Share this post


Link to post
Share on other sites

When I was got into Settings, it was set to CENTERED. The Acceleration Axxis is set to INVERTED & CENTERED and works fine that way, but not with the Brake Axxis. When I set the Brake Axxis to CENTERED, what it does is that as soon as I press the Accelerate pedal, both orange bars go forward. Ingame it also doesnt work. And if i got to what it was set to when I get into that part of the Settings, its that the Brake bar (orange) is fully in, and only if I press the acceleration pedal now, the orange bar goes away from the brake and goes to acceleration. Wtf is going on there ? I was hoping to blame that maybe on the Steering wheel, but it doesnt happen with other Games. So whats up with that ? Does anyone of you use a Logitech G920 and can show me pictures of his or her settings, so I can see what I maybe did wrong or what to setup different ? Btw, I dont have the shifter, i dont do that. I drive automatic (please spare me the comments about that. ;) Everyone's choice!) 

On the top of the Controls settings, there is like 3 pulldown menus. On the first, I chose Keyboard + Logitech G920 Steering wheel. I suppose I only would need the others if I would also use a shifter, correct ?

 

Thanks in advance.

 

Wolf

Share this post


Link to post
Share on other sites
Just now, jogger506 said:

i just got a G920 and i had that problem have you cheaked the pedal setting on the profiler. 

 

Cheaked ?

Share this post


Link to post
Share on other sites
Just now, jogger506 said:

have you tryed uninstalling and reinstalling your profiler. 

 

What do you mean with Profiler ? The Logitech Gaming software ?

Share this post


Link to post
Share on other sites

After I installed it, the Software found some of my Games, including ATS, and added a profile. Are you saying I am supposed to remove that profile or uninstall the Software ? Because the latter wouldnt make sense, since that issue is only with ATS and not other Games. Which is the strange part. But every help you can give me is greatly appreciated. ;)

 

Wolf

Share this post


Link to post
Share on other sites

Ok, here is the settings. Unfortunately I cant upload both because of some very low filesize limit. Have to add the other in another post. Sry.

20170224162610_1.jpg

 

Well, is it looks I cant even add another picture in a new post. Damn it.

Ok, try the second pic here.

 

jbe6zAW.jpg

Share this post


Link to post
Share on other sites

you can also use the console command g_brake_intenstity (number in %) e.g. g_brake_intensity 20

Share this post


Link to post
Share on other sites
9 minutes ago, Krypton418 said:

you can also use the console command g_brake_intenstity (number in %) e.g. g_brake_intensity 20

Hmm, tried that, didnt change anything. When I accelerate with the gas pedal, its going forward. As soon as I let it go, its immediate stop. Break pedal does nothing when I press it, its kinda automatically  breaking when I dont press any pedal. Damn it. :(

Share this post


Link to post
Share on other sites
30 minutes ago, jogger506 said:

ok... have you cheaked your in-game setting and settings on the ATS on Gaming software. 

Could you maybe put a screenshot of the ATS profile on Logitech Software ?

Share this post


Link to post
Share on other sites
Just now, jogger506 said:

this going to sound silly but do you have combined pedals on. if not that would be why 

You mean like if you click on the Pedals in Logitech Software and have that setting to use both  pedals ? No, I havent. ;)

 

Share this post


Link to post
Share on other sites
On 24/2/2017 at 4:51 PM, Wolfseye said:

You mean like if you click on the Pedals in Logitech Software and have that setting to use both  pedals ? No, I havent. ;)

 

I've got the G29 and that's how I have these settings, the "Use combined pedals" are unticked on both the Brake and Accelerator.

 

On the second pic you posted, I see something definitely weird... The assignment for Brake axis is the same as for Acceleration axis. These below are my settings:

Spoiler

uExJPuE.jpg

Have you tried hitting Reset to defaults and assigning them again? I just did that and by default, both Acceleration and Brake axis are assigned to the same pedal, I needed to re-assign the Brake one.

Share this post


Link to post
Share on other sites

@Wolfseye looks like to me your brakes are set to the Accelerator pedal in the screenshot click on the brake axis and push your brake pedal that should change it to Joy_Brake instead of Joy_ Accelerator because having both set to accelerator would explain why when you hit the accelerator it also applies the brakes 

Edited by bryangullickson
clarification and tagging OP

Share this post


Link to post
Share on other sites

I haver the same wheel I haven't got it setup at the moment as wife binned cpu desk and my pc is in my room hiding beside a dressing table and hooked up to my 42" flat screen lol and before anyone asked I got wireless k/b and mouse on ym bed yes I'm lazy lol

 

When I had it setup I had same issue as you did what I did was removed all settings and done a detection again (Detect controller or wheel) and after I did that it was fine.....

Edited by lxl Semper lxl
  • Upvote 1

Share this post


Link to post
Share on other sites

Thank you very much, guys, for all your help. :) As it turns out, it was simply a case of setting all to default and setting the axxises again manually. ;)

Sometimes things can be so easy.

 

However, still FFB doesnt work as good in ATS with this Steering Wheel as it does on ETS2. Which is strange, and also sad, because I really prefer ATS. Strange, considering its technically the newer Game, yet it seems not so good working as ETS2. Which also seem to play much more. I tried Multiplayer once, but as shown in most Videos on Youtube, and please dont take that personally to anyone here, too many drivers just behave like idiots and make the enjoyment a very short one. Plus, without AI traffic (although them often also being a pain in the ***), i find it somewhat less appealing. If that would be different, who knows, i might be interested more.

Plus, not sure if a Multiplayer is a good idea, when the original Game is a simulator. It mostly makes a racing Game out of the original, hence how many people drive in Multiplayer, and that just kills the attraction for me.

But I will keep my eye on the Multiplayer. ;)

Cheers

 

Wolf

 

P.S: Please forgive me if I went a bit OT....

Share this post


Link to post
Share on other sites

@Wolfseye - MP is amazing. I don't like racers, trolls, kids who are clueless about basic traffic rules, reckless players that don't care about others... But since I started playing MP, I've almost forgot about SP. If you want a more relaxed experience, try EU#1 server, look for areas where other players drive (the server is low populated) so you don't feel so alone. Cars are not allowed in that server, there's a speed limit of 60 Km/h inside cities, 110 Km/h outside cities, which helps having almost no trolls there. People who connect in EU#1 server are usually serious players, looking more for the simulation aspect of the game. The other servers, well... Cars, no speed limits, so you can feel most of the time as if you're in a different game, GTA, NFS or similar. But there are areas in the map that are quite calm, mostly the expansions Going East!, Scandinavia and Vive la France!.

Share this post


Link to post
Share on other sites

Dont get me wrong, I love driving Games like GTA 5 etc and all sorts of fun racing games (not usually the Simulator kinda guy), but what I would have preferred would be if they would have given out the Server files so everyone can make their own Server, either with their friends of public if thats what someone wants. I am not a big fan of region servers. I might take a look, but for now, the relaxing part for me is still with the Single Player. Might change in time, we'll see. ;)

Thanks.

 

Wolf

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...