Jump to content
  • 0

speed limited



My game auto updated which i have since turned off and i had to downgrade to version 1.25 ever since when i go into game i am speed limited to 68 mph even in free roam and i have speed limiter turn off but it turns itself back on as soon as i start driving

Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 1

Are you doing World of Trucks External Contracts? If you are, these jobs limit you to a specific speed limit.


Also, make sure you have the Speed Limiter turned off in the Multiplayer Tab Menu. Go Tab > Settings and at the bottom, make sure they Speed Limiter box in un-ticked.


Hope this helped.

Link to post
Share on other sites
This topic is now closed to further replies.
  • Create New...