Jump to content
  • 0

Will downgrading my game affect any in-game singleplayer mods or progress?


Question

Hey guys, brand new driver here. I just downloaded ATS around a week ago and only have about 30 hrs (probably only around ~18-20 of actual driving) in the game. I really want to try to play multiplayer, but as I have only ever played on 1.40, I am pretty clueless on how downgrading your game will work on this game in particular, as downgrading game versions on other modded games I have played can REALLY cause some serious, and sometimes even permanent damage. So I was just wondering how, if it all, it will affect my singleplayer progression and mods installed. I will list the few mods I have installed down below, just in case it can provide useful information in to how downgrading will affect my setup in particular. 

Listed in order of priority: Real Companies, Shops, & Billboards (1.40), Viper2's Peterbilt Modified v2.3 (1.39/beta 1.40), Scania Trucks for ATS, Air Brake Sound Mod (1.40), Cummins N14 Sound/Engine Pack (1.39, works in 1.40), and FMod's Cummins N14 Lope Tune Pack (1.39, works in 1.40), and Unlimited Money + XP Mod for ATS (inactive currently, but works in 1.40)

Sorry for the info dump, but I am pretty excited to play MP, however to me it is not worth corrupting all of my files and mods and having to start all over when I could just be patient and wait for the TruckersMP team to release the 1.40 update.

Thank you for any and all help you can give, this seems like an amazing community, and I am excited to be a part of it. :)

Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I'm afraid, if you have started after 1.40 version got released, you will have to create a new profile after downgrading. The saves from new version are not working on any older version. About mods, TruckersMP does not support any mod except ProMods and Grimes's weather mods, so you will not be able to use your mods multiplayer. If mods you have were made for 1.39 but they were not updated for 1.40, mods should work fine on older version (but only on singleplayer).

I propose you to wait until TruckersMP will support 1.40. It can take a couple of weeks until it will happen.

Link to post
Share on other sites
  • 0
6 minutes ago, Unnamed_User said:

I'm afraid, if you have started after 1.40 version got released, you will have to create a new profile after downgrading. The saves from new version are not working on older version. About mods, TruckersMP does not support any mod except ProMods and Grimes's weather mods. If mods you have were made for 1.39 but they were not updated for 1.40, mods should work fine on older version (but only on singleplayer).

I propose you to wait until TruckersMP will support 1.40. It can take a couple of weeks until it will happen.

Thank you so much for your input. Creating a new profile is fine for me, I just didn't want to corrupt anything I have in the 1.40 version. I am going to try to downgrade so I can play MP, as my tiny little brain had the great idea of creating a backup save file for my 1.40 progress just in case anything gets messed up. After playing with mods for going on a decade, it is baffling to me that it took me this long to come up with that idea. But thank you once again for your input, and I am going to launch 1.39 in singleplayer first, so I can disable any mods so I dont immediately get banned/kicked before I even start playing. Thanks again, and you  might get another reply if I screw anything up too bad! 🙂

Link to post
Share on other sites
  • 0

Hello there @t.tv/lionsnipeOW

 

Fist of all, welcome to TruckersMP Forum. 

 

Well, I wanna to leave my opinion, if it is useful 

 

1-)  I'm assuming your files are saved on your pc; 

 

unknown.png

 

 

2-) So my suggestion is that you make a backup of your files folder as in the photo illustration below;
 

unknown.png

 

3-) Now in-game you can create a save and still enjoy your current profile as in the photo illustration below;

unknown.png

 

 

As you can see, I have my save 1.40 with all my progress and I did downgrade 1.39 to play online. 
 

You can continue your 1.40 progress by playing singleplayer and keeping the save up to date.

As for your mods, at some point in game it will crash because some parts of the map will not load this old mod and your game will close immediately

With that in mind, don't be alarmed if you're playing and your game crash. Go back game and just remove the mod and continue the game and do update your mod 
 

Note: Remember that this is just an alternative.

  • Upvote 1

 

 

                                                                                                                                                     Be positive that everything will be fine, even in the worst moments!

 

                                                                                                                                       mud.png    1531540532_role_5Patron(4).png.063edcf85

 

 

 

Link to post
Share on other sites
  • 0

Hello there! 

 

Have you received the solution you were looking for with the replies given above? 

The confirmation of the status of your problem helps us always keep our forum organized. 

 

I await your return. 

 

Kind Regards,

SarahMaddy

TruckersMP Support

SarahMaddy TruckersMP Support

1807531239_role_SupportStaff(1).png.66ce
Languages: Spanish Flag_of_Spain.svg (primarily) | English gb.gif 

 

Report a player | Appeal a Ban | Feedback System | Forum & Ingame Rules | Supported MODs | MP Launcher Error Solutions

Need help with something, or can't find a solution to your issue? Submit a ticket with the support team here!

Link to post
Share on other sites
  • 0

Hello there! 


Your topic has been inactive for 3 days since the last reply.


Because of inactivity, I will have to move this topic to Inactive Topics.

If you have any further queries, feel free to DM me or another Support Team member and we will open this topic as per your request.

You have 1 week to contact us.

I hope you understand. 

 


Kind Regards,
Rico
TruckersMP - Support


//Locked and Moved to Inactive

Link to post
Share on other sites
  • 0

Hello there,

 

Due to this topic not wanting to be opened after 1 week of being Inactive, I will have to move it to Unsolved Topics.

If you are still having issues, feel free to contact us here: https://truckersmp.com/support

 

Kind Regards,

General18

TruckersMP Support

 

//Moved to Unsolved Topics

General18

TruckersMP - Support Team

spacer.png

My supported languages: English, Danish

Support | TruckersMP Rules | Feedback | How To Downgrade

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...