Jump to content
  • 0

The Right DownGrade Patch Currently To Play ETS2 Multiplayer


Ade_XB1_Gamer
 Share

Question

Hello, So Ive Brought Ets2 Today, Ive Got Truckers Mp And Everything is installed, but everytime i go to load truckers mp it keeps giving me this error ..... 'ETS2MP - Fatal Error. Unsupported Game Version Detected! Expected Ver, 1.36.2.55s [rev. e0862fcae485] You have ver. 1.37.1.0' i Currently have my beta thing set to 'Temporary_1_36 - 1.36_x For Incompatible Mods' and still it doesnt seem to want to let me on, im also running the TruckersMp as Administrator, Ive Played Ets2 In The Past Quite Alot But Never Online So This Is A First, Ive Watched a few videos but there is no up to date video on youtube on how to deal with this problem for 202, any help from an admin or someone who may know the right one to use would be greatful

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hello @Ade_XB1_Gamer, i hope you are well!

 

Below I leave you methods to fix your problem:

 

Method 1

 

Step 1

*Open Steam and go to your library -> games

*Make a right click on Euro Truck Simulator 2 and open Properties

*After the Properties window has opened click on Local Files tab and press Browse Local Files

*A folder with game files will open. Remember the path to this folder

Step 2

*Click Start -> Run (or WIN+R)

*Type regedit and hit enter

*Follow the path HKEY_LOCAL_MACHINE\SOFTWARE\TruckersMP

*Look at the value parameter "InstallLocationETS2"

Step 3

*Copy the folder address from Step 1

*Change the value parameter "InstallLocationETS2" (Insert the copied folder address)

*Click OK.

 

If this doesn't work:

 

Method 2

*Press the Windows Key + R (Win+R) on your keyboard
*Enter "%programdata%" and press Enter (without the quotes)
*Find the folder "TruckersMP" and delete that folder.
*Navigate to C:\Program Files\ and delete the folder named "TruckersMP Launcher"
*Go to https://truckersmp.com/download and re-download and install the Launcher with admin privileges 

Please also have a look at this knowledge-base article. 

 

Let us know if these methods worked for you.

 

Kind regards.

spacer.png

 

 

 

Link to comment
Share on other sites

  • 0

Maybe your game is still downgrading as the launcher still recognizing the 1.37 version. It is basically a full download for an older version of the game so it will take a while even if just downgrading. You can check if the game is still downloading in Steam. Or, simply uninstall the whole game and reinstall it so it will only contain the files for 1.36.

Link to comment
Share on other sites

  • 0

Hello there, 

 

I'm glad to hear the issue has been fixed!

I will go ahead and move this topic to Solved Topics, feel free to contact us again in the future if you have anymore issues. 

Thanks to all those who helped. 

Kind Regards, 
Savage 
TruckersMP Support 
 

//Locked and moved to Solved Topics 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.