Jump to content
  • 0

ATSMP and ETS2MP: "Cannot validate game version would you like to try again?"


Go to solution Solved by heyhococo,

Question

So my friend has this problem the past few days. While he was able to play American Truck Simulator Multiplayer all of a sudden he started getting that message: "Cannot validate game version would you like to try again?". He tried everything.. Deleting the game and installing it again. Updating to the latest Steam version. Completely uninstalling the multiplayer mod and installing it again through TruckrsMP. And every time he tries to launch the multiplayer mod he just gets this message.

Please any help? Any guidance?

Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 1
  • Solution

Hello and welcome to the forums! :D

This is a somewhat common problem, which can be fixed (mostly) by doing the following:

1. Run Steam as administrator (Right click steam and run as administrator)

2. Go to library, right click Euro Truck Simulator 2 and then click properties

3. Go to betas and opt out of all betas

4. Go to local files and Verify integrity of game cache

Try again with MP. If this doesn't work, then continue:

5. Go to control panel, add or remove programs and uninstall TruckersMP

6. Go to C:\Users\username\My Documents and delete TruckersMP folder

7. Go to TruckersMP.com and download the latest client

8. Go through setup. MP should be installed to C:\Program Files (x86)\TruckersMP

9. Choose your ETS2 SP and/or ATS directory, which should be:

C:\Program Files (x86)\Steam\steamapps\common\Euro Truck Simulator 2 and/or American Truck Simulator

12. Try again with MP, making sure you right click it and click Run as Administrator.

If this doesn't work, create a ticket at: https://ets2mp.com/support/(should redirect you) ;)

  • Upvote 2
Link to post
Share on other sites
  • 0

Like I said my friend already uninstalled multiple times both the mod and the game itself and he was running latest versions. Anyway it seems all of a sudden today it worked for him. I can't understand what's going on, but it's definitely something related to the mod or the main Multiplayer page/server. Now it works let' hope it stays like this.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...