Jump to content
  • 0

TruckersMP doesnt recognize Promods


Go to solution Solved by General18,

Question

My problem is simple. I can play with any problem singleplayer with promods activated, but when i go to play online, appear a "One or more required promods file is not found" message and I cant. I have the ETS2 document folder move from C to D, if this can be the problem (also, i have in ets2 launch parameters -homedir and the new directory)

Sin título.png

Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 1
  • Solution

Hello @Charly10SP,

 

mod folder on different HDD/SSD

 

If you're using the -homedir, remove that, and do the following instead :) (This method I've tested myself :))

 

1. Go to the following link: https://www.howtogeek.com/howto/16226/complete-guide-to-symbolic-links-symlinks-on-windows-or-linux/
2. Scroll down to 'How to Create Symbolic Links with a Graphical Tool' (This is WAY easier than working with the CMD 🙂 )
3. Download and install teh following: http://schinagl.priv.at/nt/hardlinkshellext/HardLinkShellExt_X64.exe
4. If it asks you to restart, just say no (I said no, and it works perfectly for me 🙂 )

 

Now, if it was installed correctly, you should be able to make the link, like so:

 

1. locate the folder (If its ONLY the mod folder that you have on the bigger drive) go to: D:\Euro Truck Simulator 2\, right-click on the mod folder, and select “Pick Link Source” in the menu
2. Now, go back to C:\Documents\Euro Truck Simulator 2\ (If there's a mod folder, ensure its empty, if not, move any files from it, to the mod folder on the D drive) now delete the mod folder from: C:\Documents\Euro Truck Simulator 2\
3. You can then right-click inside C:\Documents\Euro Truck Simulator 2\, point to the “Drop As” menu and select “Symbolic Link”

 

Thats it, your folders should now look somewhat like this: https://gyazo.com/893e59fc8772e57481b6e1b9065b40ee
Top one is C:\Documents\Euro Truck Simulator 2\
Bottom one is G:\Euro Truck Simulator 2

 

It they match up pretty well, go ahead. Start TruckersMP and join one of the Promods servers :D 

 

If you get an error about missing mods, just ignore and load your newest save, if you get another error, just hit continue, any errors about mods -> Continue/ignore


I hope this solves your problem :) 

 

Sincerely,
General18
TruckersMP Support

General18

TruckersMP - Support Team

spacer.png

My supported languages: English, Danish

Support | TruckersMP Rules | Feedback | How To Downgrade

Link to post
Share on other sites
  • 0
18 minutes ago, [VIVA] ismail [TR] said:

Hello there :) 

 

Please watch the this video to right install of Promods:

 

 

 

Hi. Thanks for your reply but I have promods correctly, otherwise it would not work in the singleplayer. I am 99% sure that there is a problem with the the change of ets2 documents directory, because i have played truckersmp with promods in the past when i have the mods on SSD and it works fine. I dont have any junction or something like that, only -homedir in  steam launch parameters

Link to post
Share on other sites
  • 0

When you generate the def file for ProMods, make sure that Special Transport option is left unchecked. Since TruckersMP won't support Special Transport DLC trailers at this moment, you have to create the def file, which doesn't have the support of mentioned DLC. 

 

If you want to ask anywhere on forums whenever 32-bit version of MP will be supported in future, try to start GTA V on your 32-bit machine before checking game's system requirements.

Instead of quoting the post above, use the ^ character. The character is actually pointing to the post above.

How to fix sudden steering issue on your USB steering wheel

Link to post
Share on other sites
  • 0
7 minutes ago, Titanic4 said:

When you generate the def file for ProMods, make sure that Special Transport option is left unchecked. Since TruckersMP won't support Special Transport DLC trailers at this moment, you have to create the def file, which doesn't have the support of mentioned DLC. 

Done, and still the same problem: 

Sin título.png

Link to post
Share on other sites
  • 0

Hello there! :)

 

We are glad to hear that you were able to solve your issue.

Thank you to everyone for helping here!

If you require more help in the future, please do not hesitate to create another Topic or a Support Ticket.

 

Kind Regards,

Krisi1051

TruckersMP - Support

 

//locked and moved to Solved Topics.

Wolves™ | Content Creator

----------------------------------------------------------------------------------------------

🇬🇧 Rules Support Feedback | Guides Ban Appeal 🇬🇧

🇭🇺 Szabályzat Támogatás | Visszajelzés | Tudásbázis Fellebbezés 🇭🇺

----------------------------------------------------------------------------------------------

TruckersMP

sVBwTEd.png & c72Zew3.png

----------------------------------------------------------------------------------------------

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...