Jump to content
  • 0
FloJov

ETS2 bug when choosing mission

Question

Hello, I am forced to contact you today because I have a problem with TruckersMp since yesterday.

Indeed, when I am trying to choose a mission with my own truck, a window opens and says" the game has stopped working". I used ETS2 two days ago and it was working normally, but now it doesn't work.

 

I tried to copy the error :

Nom de l’application défaillante eurotrucks2.exe, version : 1.36.2.24, horodatage : 0x5e203d54
Nom du module défaillant : eurotrucks2.exe, version : 1.36.2.24, horodatage : 0x5e203d54
Code d’exception : 0xc0000005
Décalage d’erreur : 0x0000000000495e55
ID du processus défaillant : 0x2a20
Heure de début de l’application défaillante : 0x01d5fc91ea19a187
Chemin d’accès de l’application défaillante : C:\Program Files (x86)\Steam\SteamApps\common\Euro Truck Simulator 2\bin\win_x64\eurotrucks2.exe
Chemin d’accès du module défaillant: C:\Program Files (x86)\Steam\SteamApps\common\Euro Truck Simulator 2\bin\win_x64\eurotrucks2.exe
ID de rapport : 8b9c39f3-6885-11ea-800a-bcee7bbed04a
Nom complet du package défaillant : -
ID de l’application relative au package défaillant : -

 

Sorry, it's in French because I am French, and I am a student aged 16, but I am trying to write to you in English as I can. 

If someone understood the topic and can help me, I will be really grateful, with the COVID 19 virus, I was supposed to kill the time on ETS2 but it seems impossible.

 

To precise, the game also closed after 5-10 minutes online.

 

I hope to hear you soon. Take care of you.

 

Flojov.

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

Hello @FloJov :) 

 

1 hour ago, FloJov said:

Hello @General18, thank you first for taking the time to answer me to reassure me a little,

Your very welcome :) 

 

6 hours ago, FloJov said:

Console ETS2.jpg

I searched some more on 'create_truncate mode', this is what i found:
 

Spoiler

check that the mentioned directories have not been set to read only

-----------------------------------------------------------------------------------------

Thanks for the help guys I found the issue. I changed something in Bitdefender which made the folder protected (i.e read only) After reverting that change I can save again! 🙂

The quick save function should display an error when it can't write to the save. Otherwise you think everything's fine and keep on playing.

 

Info about mentioned text, here: https://steamcommunity.com/app/227300/discussions/0/1693785035819234884/

 

So, what you wanna try here (Before reading on, and trying my other possible solutions I've mentioned) is:

1. Check and make sure that Bitdefender is not blocking any kinda write permissions for this folder: \Documents\Euro Truck Simulator 2\cache. If thats all good, make sure the folder and the file in this folder isn't read only

2. If you can't find any error with bitdefender, you might wanna try to remove bitdefender entirely from your pc (Don't worry, Windows 7/8/8.1/10 has Windows defender built-in. So after Bitdefender is removed, and your pc restarted, Windows defender will take over :))

 

Windows defender:

To make sure Windows defender has been enabled, you might be able to just search for 'Defender' or 'Windows defender'. If this doesn't help, you'll have to go this route:

1. Search for 'Windows Security' and open it

2. Select/click: Virus- and threat protection

3. Then scroll down to 'Settings for Virus- and threat protection' and select 'Administrate settings' 

Here you should see 'Protection in Real time' 'Enabled'. If its not enabled, then do enable it :) 

 

After this, try and play the game, see if you still get the above pictured error in the console. 

If you don't get the error, go ahead, drive :) If you can drive/play normally for a while (Try multiple short trips, and maybe a few longer trips), then I think we found the problem (Bitdefender. Alot of 3rd party anti virus software, are sometimes, a little over protecting. Trust me, I've tried it before :()

 

Now, if the game works fine/perfectly for a while, you can go ahead and update your GPU drivers like you normally do. BUT, if the game still crashes, read on down under (Because down there, I describe a way to clean install your GPU drivers (To maybe remove some errors in your current drivers. And then, install a new driver)

Link for the newest compatible driver for your GPU: Newest driver from NVIDIA's website: https://www.geforce.com/drivers/results/145873

 

 

1 hour ago, FloJov said:

Windows operating system: Windows 8.1

Darn it. I actually thought about 8/8.1. I even searched for Internet Explorer on my pc. And I found it. So I changed it to Windows 10 XD

 

1 hour ago, FloJov said:

CPU: Intel Core i3-3110M 2,40GHz
GPU : Intel HD Graphics 4000 + NVIDIA GeForce GT 720M

Since, you've ran it just fine some time ago, lets move on:

 

Theres a newer driver available for your GPU (Who knows, but sometimes a clean install of the drivers can help resolve some game crashes :) Drivers can fail aswell as pc's :))

Newest driver from NVIDIA's website: https://www.geforce.com/drivers/results/145873
When opening the installer, select either, NVIDIA graphics driver with GeForce Experience, or just the Nvidia graphics driver.

Then select 'User defined' (Advanced) 

Then, underneath the list of components to install, select: 'Perform a clean installation'

Like this (Sorry, mine is in Danish, but you just have to look at the checkmark, then read what it says on your end :)):
 

Spoiler

814455523_NVIDIAdriverinstaller-Cleaninstallation.PNG.2dc9d3d572c898389d50c87ab4e1bc09.PNG

 

1 hour ago, FloJov said:

And here is the link for the game log: https://pastebin.com/pZn2AXEd

Is this log file from a recent crash?

 

Because this looks like a regular shutdown (Not a crash)

 

Spoiler

02:58:49.763 : quit

02:58:49.763 : Creating save-game file (/steam/profiles/4A6F686E/save/autosave/game.sii) ...

02:58:49.960 : [trigger] Reset action (trig_action.cam7_on_off)

02:58:49.961 : [trigger] Reset action (Parking HUD activation (auto reset))

02:58:50.145 : [hashfs] dlc_fr.scs: Unmounted.

02:58:50.145 : [hashfs] dlc_trailers.scs: Unmounted.

02:58:50.145 : [hashfs] dlc_rocket_league.scs: Unmounted.

02:58:50.146 : [hashfs] dlc_oversize.scs: Unmounted.

02:58:50.146 : [hashfs] dlc_heavy_cargo.scs: Unmounted.

02:58:50.824 : [gfx] NVAPI unloaded

02:58:50.836 : [net]  LOG INFO: Stopped

02:58:50.857 : [hashfs] core.scs: Unmounted.

02:58:50.858 : [hashfs] def.scs: Unmounted.

02:58:50.858 : [hashfs] locale.scs: Unmounted.

02:58:50.858 : [hashfs] base_cfg.scs: Unmounted.

02:58:50.858 : [hashfs] base.scs: Unmounted.

02:58:50.858 : [hashfs] effect.scs: Unmounted.

02:58:51.561 : [sys] Process manager shutdown.

 

 

1 hour ago, FloJov said:

I think I saw some errors in the file but I let you read 🤣

I see some too, but some of them (Not all) I have in my log file too 😕

 

With all this, try mentioned things:

1. Perform clean installation of GPU drivers

2. If the log didn't contain a crash, go ahead, play the game with the newest graphics driver, and see if the game still crashes. If it does, come back here, and let us know :) 

 

Best Regards / Best Wishes

General18 - I await your response :) 


PS. I made the spoilers, to not make the post seem REALLY big XD I hope it helps :) 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hello :)

This would probably be due to you playing in DX11. The game has issues with DX11 and i would advise not to use it. 

Please change to OpenGL. To do this, head to your Steam library, click Play ETS2 and this time hit 'Launch with OpenGL'.

Start the game until it's fully loaded, save and exit the game. Launch TruckersMP again.

 

 

Also try these:

Solution 1:

> Press the Windows key + R (Win+R) on your keyboard.

> Type "%programdata%" and press Enter (without the quotation marks).

> Search for the folder "TruckersMP" and delete this folder.

> Navigate to C:\Program Files\ and delete the folder "TruckersMP Launcher".

> Go to our website and download the launcher again with administrator rights and install it https://truckersmp.com/download/

 

Solution 2:

You should start TruckersMP as administrator. This is really important.

Also try to start TruckersMP with DirectX (64).

> Go to your Steam App

> Go to library

> Go to ETS 2 / ATS

> Click on "Play".

> Select "Start with DirectX (64-bit)". Make sure you have selected 64 bit.

> Start ETS 2

> Select your profile and press "drive".

> Close ETS 2

> Start TruckersMP as administrator. TruckersMP will start with DirectX for all times. Except that you change it again.

 

Solution 3:

> Go to Steam Library

> Right click Euro Truck Simulator 2

> Properties

> Local Files

> Verify Integrity of Game Files

Wait until the game files are verified and try whether the error still occurs.

 

Solution 4:

> Update your graphics card driver.

> Be careful not to play in heavily frequented areas.

> Drag and drop your graphics settings.

> You may need a new profile, delete the old one and create a new one.

> Reinstall the mod and make sure you have placed it correctly in the directory. (\Steam\SteamApps\common\Euro Truck Simulator 2)

> Do not use unsupported mods. Also, too many mods can cause your game to crash.

> File Documents/ETSMP Delete (Please save this file before deleting)

> This can be caused by a missing game file. Go to the Steam Library / Right click on Euro Truck Simulator 2 / Properties / Local files / Check the integrity of the game files.

> Make sure you have the latest .Net Framework (4.7) & DirectX & Microsoft Visual C++ 2015 and use CCleaner to remove temporary files and obsolete registry paths.

 

Share this post


Link to post
Share on other sites
  • 0

Hello, I tried all the solutions posted by Kien Giang, and the problem is still there.

 

I can't understand why suddenly it's doing that.. I have also uninstall ETS2 and reinstall.

 

Bug truckersmp.jpg

Share this post


Link to post
Share on other sites
  • 0

Hello :) 

First you should check if there are any updates for you graphic card and windows updates.

Clean your temp files with ccleaner https://www.ccleaner.com/

 

Do you use any mods from Sp while you playing MP ?

Mods can make the game stop working

Aswell try to delete mod folder in ets2 map and try agian

Also check so there is no corrupted files in TMP folder & install fresh. ( You could try as well delete your computer cache memory by turn off and unplug power cable)

 

Then follow these guides:

1.Make sure you have the latest .Net Framework

2.Clean your temp files with CCleaner

3.Check your temp files path and make sure it's located at C:\Users\name\AppData\Local\Microsoft\Windows\INetCache

4.If you don't have "INetCache" folder make a new folder and name it "temp" and then open the Windows temp settings and choose the new path.

5. Try to clear your temp files: https://kb.wisc.edu/page.php?id=15141

https://imgur.com/a/gXl0eSe 

 

In addition to reinstalling your launcher and running it as Administrator, you can try these out too.

 

Make sure you have latest .NET Framework (or later), DirectX and Microsoft Visual C++ 2015. You can check this guide too.

You can also use CCleaner to clean files and registry errors.

 

Additionally, you can check if your Firewall/antivirus is blocking the game.

 

 

Share this post


Link to post
Share on other sites
  • 0

Hello,

as you may know, ETS2 version has changed. I will wait TruckersMP update, hoping it will solve my issue. If not, I will try the new solutions and tell you if they worked.

 

Share this post


Link to post
Share on other sites
  • 0

Hello :) 

Just now, FloJov said:

as you may know, ETS2 version has changed. I will wait TruckersMP update, hoping it will solve my issue.

With the latest update of TruckersMP, to be able to play ETS2 Multiplayer, you need to choose the version temporary_1_36 - 1.36.x for incompatible mods

Or if you get the "Unsupported Game Version detected" error

 

Follow this:

1. Open Steam

2. Right click on "Euro Truck Simulator 2"

3. Click "properties"

4. Click BETA tab and choose temporary_1_36 - 1.36.x for incompatible mods

 

Share this post


Link to post
Share on other sites
  • 0

Hello there,


Your topic has been inactive for 3 days since the last reply.
Because of inactivity, I will have to move this topic to Inactive Topics.


If you have any further queries, feel free to DM me or another Support Team member and we will open this topic as per your request.


Thanks to all participation.


Sincerely,
Beenz.
TruckersMP - Support  


//Locked and Moved to Inactive

Share this post


Link to post
Share on other sites
  • 0
On 3/19/2020 at 6:00 PM, [ETS2MCG] Kien Giang said:

Do you use any mods from Sp while you playing MP ?

 

Are you talking about DLC ? Because I have several DLC as "Vive la France" of course.

 

I am actually trying your other solutions and will come back to tell you.

 

Share this post


Link to post
Share on other sites
  • 0

So I checked, the installations that you proposed to me did not work because the good versions were already installed according to the computer.

 

I did the manipulation for the temporary files because the indicated (INet Cache) file did not exist. I also used CCleaner to delete temporary files. I then started ETS2 solo with directX, then in multiplayer and there, always the same problem.

I even tried sfc / scannow.

 

Honestly this problem is beyond me, overnight it started, and impossible to solve.

 

All I notice is that after a few minutes, it crashes, or if I select a mission, it crashes. So it may be related to backup problems? Knowing that each time I restart after a crash, the truck is not at the crash site, but at the start of the game, as if nothing was saved.

 

I remain waiting for new proposals.

Best regards,

Floflo

Share this post


Link to post
Share on other sites
  • 0

Hello,

In addition to what I've already said, I have uploaded a picture of what the in-game's console says. There are several errors.

I also saw that in my documents that I have several profiles and that the file config.cfg that is used to activate the consol is directly in the folder ETS2, and not in the folder Profile, I have also uploaded a picture to show you, maybe the issue is due to this disorder in my documents, I really don't know, so I will wait your advises.

 

Thanks a lot.

Flojov

Console ETS2.jpg

ETS2 doc1.jpg

Share this post


Link to post
Share on other sites
  • 0

Hello @FloJov
When I try to search for your problem, people mention DX11 alot.

Could you let me know of your pc specs, like:

CPU (Processor): 
GPU (Graphics card): 
Memory capacity:
Windows operating system (Looks like Windows 10): 
Windows bit version (32 or 64 bit)
Antivirus in use (Like, AVG/Avast/Windows Defender/McAfee etc):

 

Alot of this information can be found by searching for 'About your pc' in the start menu/search field. Ofcourse, in your own operating systems language ;) 
 

Together with mentioned information, could you copy-paste the whole content of your game.log.txt file after a crash (found in "Documents\Euro Truck Simulator 2\" folder) to pastebin.com 

Then paste here the generated link :) 
Assuming theres anything in there ofcourse ;) 

 

Hopefully we can figure this out :) 

 

 

Best Regards

General18

 

 

And about this:

2 hours ago, FloJov said:

I also saw that in my documents that I have several profiles and that the file config.cfg that is used to activate the consol is directly in the folder ETS2, and not in the folder Profile

Thats totally normal, thats the right place for the file to be :) 

And about the many profliles, if you want to, you can clean them up a little :) They're only backups, this is how mine looks (After cleaning up a little):

495252049_ETS2folder.PNG.d435490d3f2970746071c8b976e1a3ea.PNG

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, General18 said:

Thats totally normal, thats the right place for the file to be :) 

And about the many profliles, if you want to, you can clean them up a little :) 

Hello @General18, thank you first for taking the time to answer me to reassure me a little, so I will delete some of the profiles because they are useless.

 

Concerning my computer's properties:

 

CPU: Intel Core i3-3110M 2,40GHz
GPU : Intel HD Graphics 4000 + NVIDIA GeForce GT 720M
Memory capacity: 8 GBytes
Windows operating system: Windows 8.1
Windows bit version: 64 bit 
Antivirus: BitDefender Total Security

 

And here is the link for the game log: https://pastebin.com/pZn2AXEd

 

I think I saw some errors in the file but I let you read 🤣.

 

Hoping we will find what's wrong there.

 

See you soon

Cordially,

FloJov

Share this post


Link to post
Share on other sites
  • 0

Hello @General18,

 

 

Now that you tell me, I remember that when I launched TruckersMP, BitDefender opened to alert of a connection but I seem to have created an exception. Well I looked a little but I did not find how to check this, so I will uninstall ETS2 as well as TruckersMP, and I will see when reinstalling if the notification comes back, maybe there I will see the problem, because even in disabling BT, the game crashes.

 

And like I said, it crashes when at the top left, the backup logo appears, so that's really the problem.
I also downloaded last week an application which updated the drivers, and it did it for my Geforce, I will recheck with your link but normally, it's done.

 

It's a shame because all the forum posts that concern me especially in relation to the antivirus are unresolved,

 

I'll keep you posted.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hey @General18 and @[ETS2MCG] Kien Giang

Good and well here I am again, I come back from a delivery !!!!! 👌🚚

 

MY PROBLEM IS FIXED !!!!! 🧰

 

Indeed, it came from BitDefender.

What I did :

-Uninstall TruckersMP

-Desactivate Bitdefender including Firewall

-Download again TMP

-Install as administrator

-Add all the files and all all all all the folders concerning ETS2 AND TruckersMP in the exceptions

 

Now it's working well, thanks a lot for the time you took to give me a solution, I was about to give up 🤣

 

 

I do not understand why suddenly the antivirus said itself it was necessary to block these connections of TruckersMP...By doing so, it prevents backups and therefore causes the game to crash.

 

 Thanks again for the time spent on my problem, and maybe see you soon on the game😉

 

Best regards,

FloJov

  • Love it! 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...