Jump to content

Question

Hello, i just updated my ETS2 and somehow the game started using my gpu 100% and my pc started making some noises which sounds like damaging my pc. Does anyone have the same problem?

 

(Btw its my first time using Forum i hope im making this topic in the right place)

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 1

Hey ~Albino~ :) 

 

What version were your ETS2 before updating?
Not so long ago, DirectX 11 was fully implemented to the game, so now the game can utilize a few more CPU cores/threads, hereby, the game can run at more frames pr. sec.

If your getting quite a few FPS, it could be 'Coil whine' your getting from your GPU (Its harmless. But can be annoying to hear)

To see if its coil whine, just enable VSync in settings, so that the game only runs at your monitors rated Hz (FPS). If the noise/coil whine stops. You can either leave Vsync on, or not (Depends, if you wanna hear the coil whine or not ;) If you leave Vsync on, you'll not only save youe ears. You'll also save some power/heat :D )

 

I hope this help solve your problem/answer your question, if not, let us know :) 

 

Best Regards

General18

  • Love it! 1

Share this post


Link to post
Share on other sites
  • 0
53 minutes ago, General18 said:

Hey ~Albino~ :) 

 

What version were your ETS2 before updating?
Not so long ago, DirectX 11 was fully implemented to the game, so now the game can utilize a few more CPU cores/threads, hereby, the game can run at more frames pr. sec.

If your getting quite a few FPS, it could be 'Coil whine' your getting from your GPU (Its harmless. But can be annoying to hear)

To see if its coil whine, just enable VSync in settings, so that the game only runs at your monitors rated Hz (FPS). If the noise/coil whine stops. You can either leave Vsync on, or not (Depends, if you wanna hear the coil whine or not ;) If you leave Vsync on, you'll not only save youe ears. You'll also save some power/heat :D )

 

I hope this help solve your problem/answer your question, if not, let us know :) 

 

Best Regards

General18

Hello General18,

 

Thx for your answer. Well i do have a good PC tbh. I got i7-8700K, 11 GB Nvidia GTX 1080ti and 32 GB DDR4 Ram. And its only happening on ETS2. Not only MP also single player mod.

Share this post


Link to post
Share on other sites
  • 0
17 minutes ago, ~Albino~ said:

Hello General18,

 

Thx for your answer. Well i do have a good PC tbh. I got i7-8700K, 11 GB Nvidia GTX 1080ti and 32 GB DDR4 Ram. And its only happening on ETS2. Not only MP also single player mod.

 

With that CPU + GPU it could very well be, coil whine. Test with Vsync when possible :)

 

 

Best Regards

General18

  • Love it! 1

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, General18 said:

 

With that CPU + GPU it could very well be, coil whine. Test with Vsync when possible :)

 

 

Best Regards

General18

It worked thank you so muchhh ❤️ now i can keep playing :D and @NightSword^ yes sir i got my answer feel free to lock it thanks again ❤️ 

  • Thanks 1
  • Love it! 1

Share this post


Link to post
Share on other sites
  • 0

Hello there! :)

 

We are glad to hear that you were able to solve your issue.

Thank you to @General18 for helping here! :wub:

If you require more help in the future, please do not hesitate to create another Topic or a Support Ticket.

 

Kind regards

Linciano

TruckersMP Support

 

//locked and moved to Solved Topics.

  • Thanks 1
  • Love it! 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...