Jump to content
  • 0
pacmanarea51

Connection error issue with launcher

Question

Hello, 

 

I "upgraded" to windows 8.1 from a win 8 machine and since the update of OS, I haven't been able to launch ETS2MP. 

 

As soon as I start the launcher, it comes up with an error message titled "Connection Error - Retry?"

 

From there, there is a bunch of text that you can read on the image below.

 

I have reinstalled the launcher multiple times, and ran it as administrator couple times aswell. I have also downloaded and installed both 32 and 64bit version of .NET Framework.4.6.2.

 

I have also restarted my computer inbetween the installations of both the .NET and launcher. Nothing seems to fix the issue. Clicking "OK" on the error message allows me to enter the launcher, but I can't see any images on the launcher and I can not install available updates, another error message pops up titled the same, saying "An exception occurred during a WebClient request. Press OK to retry" Retrying never works and the error messages keeps coming up.

 

I'm out of options, can't find this exact error message anywhere else.

provlem.png

TruckersMP issue.png

TruckersMPissue2.png

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 1

Hello @pacmanarea51

Follow to guide:
 
Press the Windows Key + R (Win+R) on your keyboard
Enter "%programdata%" and press Enter (without the quotes)
Find the folder "TruckersMP" and delete that folder.
Navigate to C:\Program Files\ and delete the folder named "TruckersMP Launcher"
Go to our website and re-download and install the Launcher with admin privileges https://truckersmp.com/download/
Open The Launcher with admin privileges and click "Install Available Updates" 
https://forum.truckersmp.com/index.php?/topic/41492-launcher-errors-knowledgebase/

 

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

hello

try the possible solution steps.
 

Remove the network cable between your modem and your computer, and plug it back in after a period of time.

Restart your modem. - (Reset).

Try using VPN.

If the problem persists for a long time, get support from your Internet provider.
 

Also, make sure that the Windows firewall does not block your connection. Open the Windows firewall and say Restore defaults.

c0ab01c8ed1646078c9dfe10439a4d3b.png

 

 

Best Regards

Soul Knight:)

Share this post


Link to post
Share on other sites
  • 0

Hello :) 

Follow these guides:

Solution 1:

  • Download Ultrasurf.
  • Run Ultrasurf.
  • Open TruckersMP in Administrator Mode.
  • Install the available updates (only the first run with Ultrasurf), wait for it to finish and Launch button appears.
  • Exit Ultrasurf

Solution 2:

  • In order to verify your game cache, go to your 'Library' and find 'Euro Truck Simulator 2'.
  • Once you find it, 'Right Click' and go to the 'Properties ' tab.
  • This will open up the properties tab. Go to the third sub-tab that says 'Local Files' where you will be presented with the following options.
  • Click on the last option to begin the validation process. This might take a few minutes.
  • Once all the files are validated, if any corrupt instances are found, then Steam will redownload those particular files for you. If not you will be greeted with a box that says no errors.
  • You have verified your game cache successfully.

Solution 3:

  1. "Usually it appears when you try to update the multiplayer launcher with the game open.
  2. First, check if ETS2 process is running. If so, end it and try again. If this doesn't help delete core_ets2mp.dll, re-open launcher and re-download file.  Path: C:\ProgramData\TruckersMP"

 

Also read these topics:

 

Share this post


Link to post
Share on other sites
  • 0

The issue has been resolved.

 

Apparently all forum posts that attempt fixing this issue are meant for 32 bit systems. Going through the link posted on these forum answers will direct you to downloading the 32bit program

 

I'm running on 64 bit and there was a problem on the 64 bit version of Microsoft .NET Framework 4.6.2. So I repaired the 64 bit redistributable from control panel and restarted the computer and the launcher now works. Thank you @BL4CK$K1LL for attempting to help resolve this however.

  • Like 1
  • Thanks 1
  • Love it! 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...