Jump to content

Question

Hi.

Recently (about 13 days ago) me and my friends can not connect to multiplayer mode. the game load fine, can go to city, get jobs and etc BUT the error shows on the bottom of screen and says: " can not connect to server " and will try 10 seconds later but nothing happened after 10 sec and get same error again ! also, it doesn't matter which server we choose, we got this error in every server!

 

So, is your server have issue with Iranians IP ? because when we use VPN, everything become normal ( except  ping that become upper than 200ms ! ) and we can play together.

 

Thanks.

20200412171712_1.jpg

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Hello :)

Try these:

1. Try turning your router off for 1 minute and then turning it back on and see if you still have connection problems

2. Try clearing your DNS cache, follow this link for the guide https://documentation.cpanel.net/display/CKB/How+To+Clear+Your+DNS+Cache

3. Try changing your DNS to Google's one and see if that has any effect https://www.techworm.net/2016/08/change-default-dns-google-dns-fast-internet-speeds.html

4. Try re-setting your win-sock cache 

 

Click on windows search program and type "cmd" enter (run cmd as an admin, right click run as admin)

Once you're in, type "netsh winsock reset catalog" enter

Type "netsh int ip reset.log hit" enter

Restart your computer

 

Reset your network adapter, firewall and DHCP.

 

This page will guide you through what you need to do and explains for different Windows operating systems as you scroll down. 

https://kb.wisc.edu/page.php?id=6653 

 

You type 

 

·         netsh int ip reset reset.txt

·         netsh winsock reset

·         netsh advfirewall reset

 

into a command prompt window

 

Also make your your internet doesn't block the connection 

 

And try this:

 

Share this post


Link to post
Share on other sites
  • 0

Hello there!

 

Has your problem been solved with the above solution suggestion?

Your confirmation of the status of your issue helps us keep the forum always organized!

I await your return!

Kind Regards
Sabbi [GER]
TruckersMP Support

Share this post


Link to post
Share on other sites
  • 0
On 4/12/2020 at 10:00 PM, [ETS2MCG] Kien Giang said:

Hello :)

Try these:

1. Try turning your router off for 1 minute and then turning it back on and see if you still have connection problems

2. Try clearing your DNS cache, follow this link for the guide https://documentation.cpanel.net/display/CKB/How+To+Clear+Your+DNS+Cache

3. Try changing your DNS to Google's one and see if that has any effect https://www.techworm.net/2016/08/change-default-dns-google-dns-fast-internet-speeds.html

4. Try re-setting your win-sock cache 

 

Click on windows search program and type "cmd" enter (run cmd as an admin, right click run as admin)

Once you're in, type "netsh winsock reset catalog" enter

Type "netsh int ip reset.log hit" enter

Restart your computer

 

Reset your network adapter, firewall and DHCP.

 

This page will guide you through what you need to do and explains for different Windows operating systems as you scroll down. 

https://kb.wisc.edu/page.php?id=6653 

 

You type 

 

·         netsh int ip reset reset.txt

·         netsh winsock reset

·         netsh advfirewall reset

 

into a command prompt window

 

Also make your your internet doesn't block the connection 

 

And try this:

 

 

 

Nope. non of them work

Share this post


Link to post
Share on other sites
  • 0

Hello :) 

Have you tried to use VPN programs to play ?

Have you managed to connect at all? If you could give it a go this morning/later today and see if you're still getting that message.

 

And have you tried reinstalling TruckersMP launcher ?

Follow this:

  • Press the Windows Key + R (Win+R) on your keyboard
  • Enter "%programdata%" and press Enter (without the quotes)
  • Find the folder "TruckersMP" and delete that folder.
  • Navigate to C:\Program Files\ and delete the folder named "TruckersMP Launcher"
  • Go to our website and re-download and install the Launcher with admin privileges https://truckersmp.com/download/
  • Open The Launcher with admin privileges and click "Install Available Updates" 

If it still doesn't work, try these

Solution 1:

Verify the router or modem if the "UPNP" option is active, you usually find this option in the configures of your modem / router entering through the IP, for example: "192.168.1.1".

 

Solution 2:

And try this

 

Share this post


Link to post
Share on other sites
  • 0
19 hours ago, [ETS2MCG] Kien Giang said:

Hello :) 

Have you tried to use VPN programs to play ?

Have you managed to connect at all? If you could give it a go this morning/later today and see if you're still getting that message.

 

And have you tried reinstalling TruckersMP launcher ?

Follow this:

  • Press the Windows Key + R (Win+R) on your keyboard
  • Enter "%programdata%" and press Enter (without the quotes)
  • Find the folder "TruckersMP" and delete that folder.
  • Navigate to C:\Program Files\ and delete the folder named "TruckersMP Launcher"
  • Go to our website and re-download and install the Launcher with admin privileges https://truckersmp.com/download/
  • Open The Launcher with admin privileges and click "Install Available Updates" 

If it still doesn't work, try these

Solution 1:

Verify the router or modem if the "UPNP" option is active, you usually find this option in the configures of your modem / router entering through the IP, for example: "192.168.1.1".

 

Solution 2:

And try this

 

 

 

Hi.

 

Thanks for answering,non of your solutions working and My problem still exist !

Only if i use VPN services, i can connect to server!

 

I also change my ISP and still have same issue !

 

Share this post


Link to post
Share on other sites
  • 0

Hello there! :)

 

Your topic has been inactive for 3 days since the last reply.
Because of inactivity, I will have to move this Topic to Inactive Topics.
If you still have Questions and want your Topic to be reopened, feel free to message me or our Support Team members, we will open this Topic again.

 

Kind regards

Linciano

TruckersMP Support

 

//locked and moved to Inactive Topics.

Share this post


Link to post
Share on other sites
  • 0

Hello there, 


As this topic has been inactive for a further seven days, we will have to move it to the Unsolved Section.

Please do not hesitate to contact us again by creating another topic or via a Support Ticket!

- https://truckersmp.com/support/ticket/create
- https://truckersmp.com/knowledge-base/article/21

Kind Regards,
Jamie R
Support Team
TruckersMP.

//Moved to Unsolved.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...