Jump to content
  • 0
Sign in to follow this  
din mamma

Missing dlc

Question

So im trying to load into ets2mp but then it goes to the latest save files. Yesterday I bought some new dlc that works perfeclty on sp but when I log on mp it says missing dlc. I have tried to reinstall all mods, verify game files, restart the computer. Idk can I get some help mp be acting hella dumb

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 1

Hello there, Did you install the game via an alternate directory? The installer simply uses the default file directory which Steam installs game to. In most cases this is where users will have it. However, if during the game installation you chose to install it to a different directory, the game will not see this missing DLCs.

Try the solution below and tell us!

Step 1

  • Open Steam and go to your library -> games
  • Make a right click on Euro Truck Simulator 2 and open Properties
  • After the Properties window has opened click on Local Files tab and press Browse Local Files
  • A folder with game files will open. Remember the path to this folder

Step 2

  • Click Start -> Run (or WIN+R)
  • Type regedit and hit enter
  • Follow the path HKEY_LOCAL_MACHINE\SOFTWARE\TruckersMP
  • Look at the value parameter "InstallLocationETS2"?

Step 3

  • Copy the folder address from Step 1
  • Change the value parameter "InstallLocationETS2" (Insert the copied folder address)
  • Click OK.

Best Regards,

#Creathy

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

Hi there,

Please try and uninstall the affected DLC and install it again to try and fix this problem.

 

1. Open steam, go to library and right click on ETS2. Then click properties. https://prnt.sc/gkc5m1

2. Click the DLC tab and un-check all the DLCs which don't work https://prnt.sc/gkc5m1

3. Wait for them to uninstall then check the boxes again for them to install again

4. Wait for them to install again. 

5. Open ETS2 and check that all DLCs work

 

If this doesnt work then then verify your file integrity.

 

1. Follow up to step [2] in the above list but click "Local Files" tab

2. Click "Verify file integrity" 

3. Wait for steam to verify

4. Open the game and test DLCs.

(verify your DLCs from here https://truckersmp.com/profile/settings/redirect/dlc)

Remember your steam profile is set to Public (Steam profile -> Edit profile -> My privacy settings, and make sure that both My profile and Game details are set to Public.)

 

Also you can try uninstall the launcher and install-ed again  

1. Go to This Computer folder - Program Files - TruckersMP

2. Open folder ,which have a name TruckersMP Launcher

3. Next ,there is uninstall , so you click on it  Here is photo: https://imgur.com/a/J3cCiGh

4. If you have it done ,then you can go to Documents-ETS 2 MP and ATS MP folders deleted.

5. You have it ? 

6. So you can go to Webside TruckersMP  - truckersmp.com

7. As next you can downloaded a multiplayer version again . Link is here : https://truckersmp.com/download

Share this post


Link to post
Share on other sites
  • 0

Hello there!

 

Has your problem been solved with the above solution suggestions?

Your confirmation of the status of your issue helps us keep the forum always organized!

I await your return!

Kind Regrads
Sabbi [GER]
TruckersMP Support

Share this post


Link to post
Share on other sites
  • 0

Hello there! :)

 

We are glad to hear that your Problem has been solved.

Thank you to everyone, who helped here! 

If you require more help in the future, please do not hesitate to create another Topic or a Support Ticket.

 

Kind regards

Linciano

TruckersMP Support

 

//locked and moved to Solved Topics

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...