Jump to content
  • 0
Snake31337

Micro stuttering/Lag (not related to ping)

Question

9 answers to this question

Recommended Posts

  • 1

Maybe you're facing with "bottleneck" issue. 

Try to defragment your HDD.

 

And these are the solutions that i found at Google.

 

If you're using NVidia product:

Quote

Documents\Euro Truck Simulator 2\
Open config.cfg with notepad and search for "g_save_format" "2" if you see number 2 change it to 1 .
then go to your profile folder then find config.cfg. Do the same thing. Open with notepad and search for "g_save_idx" "1" needs to be 1. I have GTX 7704GB and I have no problem like lags or stuttering. Maybe you need to check out Nvida Control Panel and change some settings.

 

Second solution way:

Quote

I fixed many of my performance issues by going into the 'Set Launch Options' in the ETS2 and putting in this command:

-homedir g:\'

' being the name of the folder being created (you can change ' to whatever folder name you want)

set g to whatever drive you have the game installed on. Launch the game. Shut it off. go to Documents\Euro Truck Simulator 2 and copy everything. Now go to G drive, or whatever you set it as, open the folder '

There will be a Euro Truck Simulator 2 folder in there, paste everything from the documents folder in there.

Now run the game, your save should be there, and hopefully it will run better.

 

Share this post


Link to post
Share on other sites
  • 1
3 hours ago, Snake31337 said:

I tried all of the 3 ways. It seemed to me that it fixed it but it still lags a bit. Nonetheless, thanks for your help

 

I'm happy to hear that your problem is kinda solved. So, let's try to solve the rest. You don't have to reinstall your graphic card. Just always keep that up to date. Check out your other Windows updates. If there's exist few updates, install them.

 

On the other hand, if your hardware is not that good, try to decrease your graphic settings. In the multiplayer mode; press TAB and uncheck the Cabin Accessories option.

Share this post


Link to post
Share on other sites
  • 0
16 hours ago, kuzn8s said:

 

I'm happy to hear that your problem is kinda solved. So, let's try to solve the rest. You don't have to reinstall your graphic card. Just always keep that up to date. Check out your other Windows updates. If there's exist few updates, install them.

 

On the other hand, if your hardware is not that good, try to decrease your graphic settings. In the multiplayer mode; press TAB and uncheck the Cabin Accessories option.

 

20 hours ago, DJFrontier said:

Hello, some answers were given above, has your problem been solved?

I await your return!

 

Nope. I updated the graphics card drivers, it's still lagging. I'm going to try updating windows and see how it goes.

Yes, my hardware is not good, everything is on low (I disabled everything I could, even Cabin Accessories). I still think the lag can be somehow fixed since this is happening since some of the last updates.

 

@DJFrontier

No it hasn't been solved yet :(

 

Thanks to everyone for their help, hopefully someone comes up with something 

Share this post


Link to post
Share on other sites
  • 0

I think I found a fix that works, I'm still gonna wait like 2 days to test it.

 

1 The first thing I did was to check the HDMI cable (in my case the VGA cable :( old pc). 

   Source: https://forums.tomshardware.com/threads/all-games-micro-stuttering.2596572/

 

 

2 The second thing i tried was to:

    1. Run cmd as administrator

    2. Type (bcdedit /set disabledynamictick yes)

    3. Profit?

    Source: https://linustechtips.com/main/topic/391091-how-to-fix-or-reduce-micro-stuttering-in-every-game/

 

I don't know which of the two did it, but that's probably it. As I said, I'm still gonna wait 2 days to test it better. 

 

Again, thanks to everyone for your help ;)

 

@kuzn8s

@DJFrontier

 

p.s. i hope i don't forget to update you if it works or not

  • Love it! 1

Share this post


Link to post
Share on other sites
  • 0

Yeah so, I've tried playing a bit, going around the town. The lag now is much more rare. My CPU is probably the problem, since it's at like +90% when I'm running ETS2. And add to that discord, it's 100%.

 

So yeah I guess now it's kind of solved

Share this post


Link to post
Share on other sites
  • 0

Hello There!

 

We are glad to hear that the problem was solved :) 

Thanks for all participation!

Don't hesitate to contact us again if you need any help in the future.

 

Best regards,

Dominik (iFlufy)

TruckersMP Support & Translator

 

//Locked and Moved to Solved Topics

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×