Jump to content
  • 2

Question

Hi Community,

 

Thanks for reading this topic! Since this week i have lots of trouble with lagg, its soo annoying. I know its not my computer for sure. Since it 

runned ETS 2 always good. But now with everything i do my game freezes for arround 10secs and then continue. For example im loading in and 

choose what server i want to join after that click my game freezes for couple seconds and then the mouse click has an action.

Aswell with driving it freezes, and then i get kicked for "unreliable connection" Im getting really frustrated.

Can please someoene help me. (This problem does aswell occur on singeplayer)

 

Best kinds,

Tim

PC specs

i5-4440

16GB Ram DDR3

GTX 970

 

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 3

Hello,

with those huge lags should help reducing the number of employees, for example 10 employees is enough. Its the main producer of lags.

 

And to your Unreialible Conneciton:

There isn't any specific fix which will fix the problem instantly, but there are couple common fixes which could help avoid getting kicked.

  • Avoid using Wi-Fi.
  • Avoid uploading or downloading and playing MP at the same time.
  • Avoid doing Windows Updates at the same time.
  • Avoid having too many users or devices at the same time into your network.
  • Avoid using streaming services at the same time.
  • Check your firewall settings into your router/switch.
  • Prefer using servers nearest to your location.
  • Try to talk with your ISP (Internet Service Provider) and see if you can come up with a solution. Ask your ISP if they support internet profiles such as "FastPath" or "Interleave" and ask for Interleave. Interleave will raise your ping but it will do more packet checks by your ISP.

 

Best Regards,

//ASIR

Share this post


Link to post
Share on other sites
  • 1

Please try to start TruckersMP always as administrator. Please also try to control your internet connection (like ping) because this problem is expiring if your connection isn't reliable and your ping is maybe too high which causes into the server kick. 
In most cases this error is a result of too high packet loss caused by your internet connection ---- Your internet conection you can check here : https://www.speedtest.net/  

I

 

First solution

  1. You should start TruckersMP as an admin. This is really important.
  2. Also, try to start TruckersMP with DirectX (64)
  3. > Go to your steam App
  4. > Go to the library
  5. > Go to ETS 2 / ATS
  6. > Click "Play" 
  7. > Choose "Launch with DirectX (64-bit). Make sure you chose 64 bit.
  8. > Start ETS 2
  9. > Choose your profile and press "drive"
  10. > Close ETS 2
  11. > Start TruckersMP as admin. TruckersMP will start with DirectX for all time. Except you change it again.

 

Second solution 

Solution 4:

  1. > Update your graphics card driver.
  2. > Take care not to play in busy areas.
  3. > Pull down your graphics settings.
  4. > You maybe need a new profile, delete old and get a new one.
  5. > Reinstall the mod and make sure that you put correctly in the directory. (\Steam\SteamApps\common\Euro Truck Simulator 2)

 

Third solution

If it does not work, try this:

1.) Press the Windows Key + R (Win+R) on your keyboard
2.) Enter "%programdata%" and press Enter (without the quotes)
3.) Find the folder "TruckersMP" and delete that folder.
4.) Navigate to C:\Program Files\ and delete the folder named "TruckersMP Launcher"
5.) Go to our website and re-download and install the Launcher with admin privileges https://truckersmp.com/download/
6.) Open The Launcher with admin privileges and click "Install Available Updates"    ----- ALSO DO NOT FORGET ON DELETE THE 2 FOLDERS FROM DOCUMENTS - ETS2 MP/ATS MP

 

Fourth solution 

  1. Go to Local Disk (C or D  just , where you have a steam installed)
  2. Program Files(x86) 
  3. Steam 
  4. Steamapps
  5. Common
  6. Bin -- and two folders in bin , that are called x64 and x86 please delete :) 
  7. After this step , you go to steam library
  8. Click on Euro Truck Simulator 2 and start it with DirectX(64bit) 
  9. You will got a one error , that two folders missing in Steam directory. --- Do not worry , because when you click on OK , steam will be automatically installed two folders and then you can normally start with DirectX 

 

 

 

 

Also , I recommend you check this topics about lags , because is possible , that you have a some issues with FPS due to Graphics Card or something like that  :

 

 

 

 

Good Luck with your problem!

 

Hope that will be helpful^^

 

Sincerely,

 

-----[RLC] Dark_Owl_-----

 

TruckersMP Members

Share this post


Link to post
Share on other sites
  • 0
4 minutes ago, ASIR [CZE] said:

Hello,

with those huge lags should help reducing the number of employees, for example 10 employees is enough. Its the main producer of lags.

 

And to your Unreialible Conneciton:

There isn't any specific fix which will fix the problem instantly, but there are couple common fixes which could help avoid getting kicked.

  • Avoid using Wi-Fi.
  • Avoid uploading or downloading and playing MP at the same time.
  • Avoid doing Windows Updates at the same time.
  • Avoid having too many users or devices at the same time into your network.
  • Avoid using streaming services at the same time.
  • Check your firewall settings into your router/switch.
  • Prefer using servers nearest to your location.
  • Try to talk with your ISP (Internet Service Provider) and see if you can come up with a solution. Ask your ISP if they support internet profiles such as "FastPath" or "Interleave" and ask for Interleave. Interleave will raise your ping but it will do more packet checks by your ISP.

 

Best Regards,

//ASIR

 

Hey Asir!

Thanks for you're quick reply ;)
This is not a Ethernet problem, i have a good connection. 
I took a look on the Troubleshoot post, but i cant find my problem.
if you want i can make a video quick for you.

Best kinds,

Tim

Share this post


Link to post
Share on other sites
  • 0

@tifo007 Sometimes the unreliable connection is caused by the computer that cannot handle the load of data from the server.

  • Make sure you disable season effects, flags, and cabin accessories from the TMP options
  • Reduce or disable development logging (also TMP options)
  • If you have done save editing before, to reduce auto save lag, put the option back to: uset g_save_format "0"
  • Dismiss all the employees in single player (or keep a few)
  • Optionally, buying some of the trailer DLC might help a bit too

Can you also provide the game log?

 

Share this post


Link to post
Share on other sites
  • 0

Thank you all for the help!

i found somewhere on google to resolve this problem (i know its really weird) but atleast it works for me!
If you have a NVDIA graphic card. Go to your desktop and click "NVDIA Control Panel" Then go you to settings and click

Power Mode to Adaptive. This worked for me!

Share this post


Link to post
Share on other sites
  • 0

Hello there,

 

Question answered, thanks for the help.

Happy truckin all!

 

Best Regards,
[RLC] Phonyang

TruckersMP - Support

 

//locked and moved to solved. 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...