Jump to content
  • 0

Loading screen Time


BubbleMuscles
 Share

Question

Hello
after the 1.34 update ny game taking much time on loading screen. Before that i need 5-6 sec on loading screen. But now i need 30-40 sec on that. Is that from game settings or this problem occurs from my PC. Also on loading time i cannot do anything, its like game freeze.

 

                                                                 2

                                                                                                                          

                                                                              

 

 

Link to comment
Share on other sites

10 answers to this question

Recommended Posts

  • 0
Guest Ah Bunker

Hi,

First be sure so you have checked the steam files.

From the Library section, right-click on the game and select Properties from the menu.

Select the Local files tab and click the Verify integrity of game files... button.

Steam will verify the game's files - this process may take several minutes.

 

And delete the old installer and download fresh and than run it as admin.

aslo lets delete your pc' cache as well.

by doing these steps.

 

Turn off your computer and remove power cable, wait 30 secs and start anything up, try agian

 

Regards

Total EDM

Link to comment
Share on other sites

  • 0
6 hours ago, Total EDM said:

Hi,

First be sure so you have checked the steam files.

From the Library section, right-click on the game and select Properties from the menu.

Select the Local files tab and click the Verify integrity of game files... button.

Steam will verify the game's files - this process may take several minutes.

 

And delete the old installer and download fresh and than run it as admin.

aslo lets delete your pc' cache as well.

by doing these steps.

 

Turn off your computer and remove power cable, wait 30 secs and start anything up, try agian

 

Regards

Total EDM

I tried that before, even get a new windows. but same problem 

 

4 hours ago, Sentinel_ said:

Try defragmenting your hard drive (don’t defragment if you have an SSD)

 

Also, you can press esc at dstart to skip splash screen.

Yea i use SSD , i seted defragment to daily. this only happens on ets2 .

                                                                 2

                                                                                                                          

                                                                              

 

 

Link to comment
Share on other sites

  • 0

Hey friend :)

Are you using some Mods in Single Player ?

Does it happen in Single Player ? Or only Multiplayer or both ?

Are you sure your PC are in the latest version of the .Net Framework? You probably get this error because the older versions of the .Net Framework cannot match C++ credits.

Important: If the .net framework is lower than the version .Net Framework 4. Firslty, download the 4th version and then install the 4.6 version. (If you have already 4. version or upper versions, download the 4.6 version directly)

You can download and install .NET Framework 4.6.2 here and install VisualC++ 2015 here

 

Also try these:

Solution 1:

Reinstall TruckersMP Launcher:

1. Press the Windows Key + R (Win+R) on your keyboard

2. Enter "%programdata%" and press Enter (without the quotes)

3. Find the folder "TruckersMP" and delete that folder.

4. Navigate to C:\Program Files\ and delete the folder named "TruckersMP Launcher"

5. Go to our website and re-download and install the Launcher with admin privileges https://truckersmp.com/download/

 

Solution 2:

You should start TruckersMP as admin. This is really important.

Also, try to start TruckersMP with DirectX (64)

Guide:

> Go to your steam App
> Go to the library
> Go to ETS 2 / ATS
> Click "Play" 
> Choose "Launch with DirectX (64-bit). Make sure you chose 64 bit.
> Start ETS 2
> Choose your profile and press "drive"
> Close ETS 2
> Start TruckersMP as admin. TruckersMP will start with DirectX for all time. Except you change it again.

 

Solution 3:

1. Right click ETS 2 in steam

2. Select 'Launch with OpenGL'

3. Let the game run and try going into game.

4. Exit the game and go back to steam, right click ETS 2 again but this time select 'Launch with DirectX (64-Bit)

5. Again go into game and then exit.

6. Start TruckersMP up and see if the game stops crashing

 

Link to comment
Share on other sites

  • 0
49 minutes ago, [ETS2MCG] Kien Giang said:

Hey friend :)

Are you using some Mods in Single Player ?

Does it happen in Single Player ? Or only Multiplayer or both ?

Are you sure your PC are in the latest version of the .Net Framework? You probably get this error because the older versions of the .Net Framework cannot match C++ credits.

Important: If the .net framework is lower than the version .Net Framework 4. Firslty, download the 4th version and then install the 4.6 version. (If you have already 4. version or upper versions, download the 4.6 version directly)

You can download and install .NET Framework 4.6.2 here and install VisualC++ 2015 here

 

Also try these:

Solution 1:

Reinstall TruckersMP Launcher:

1. Press the Windows Key + R (Win+R) on your keyboard

2. Enter "%programdata%" and press Enter (without the quotes)

3. Find the folder "TruckersMP" and delete that folder.

4. Navigate to C:\Program Files\ and delete the folder named "TruckersMP Launcher"

5. Go to our website and re-download and install the Launcher with admin privileges https://truckersmp.com/download/

 

Solution 2:

You should start TruckersMP as admin. This is really important.

Also, try to start TruckersMP with DirectX (64)

Guide:

> Go to your steam App
> Go to the library
> Go to ETS 2 / ATS
> Click "Play" 
> Choose "Launch with DirectX (64-bit). Make sure you chose 64 bit.
> Start ETS 2
> Choose your profile and press "drive"
> Close ETS 2
> Start TruckersMP as admin. TruckersMP will start with DirectX for all time. Except you change it again.

 

Solution 3:

1. Right click ETS 2 in steam

2. Select 'Launch with OpenGL'

3. Let the game run and try going into game.

4. Exit the game and go back to steam, right click ETS 2 again but this time select 'Launch with DirectX (64-Bit)

5. Again go into game and then exit.

6. Start TruckersMP up and see if the game stops crashing

 

 

 

Thanks for reply . but sorry i did that before.this occurs single player and multiplayer. i used one mod, but when this problem started , i remove that that. even try with brand new profile / got a new windows. nothing change :(

                                                                 2

                                                                                                                          

                                                                              

 

 

Link to comment
Share on other sites

  • 0

Hello :)

Then can you try these:

Solution 1:

  • Open Documents
  • ETS2
  • Profiles
  • Which profıle you use is that proceeding profıt
  • Open confıg
  • Chance  (g_save_format "0'') to (g_save_format "2")

Solution 2:

Step 1. Right click your 'Euro Truck Simulator 2 Multiplayer' / 'American Truck Simulators Multiplayer' .exe file, whether it be the shortcut on the desktop or actual file and then click properties.

 

Step 2.

If you right clicked it's shortcut, make sure you clicked the shortcut tab.

-----------------------------------------------------------------------------------------

If you clicked the .exe file, make sure you are on the general tab.

You should see a section say: (   Target: "C:\Program Files\TruckersMP\launcher_ets2mp.exe"   ) OR it's custom install path. (Minus the brackets)

What you need to do is on the end of it, add: (   -homedir C:\Users\Michael\Documents\ETS2MP   ) 

It should look something like: (   Target: "C:\Program Files\TruckersMP\launcher_ets2mp.exe" -homedir C:\Users\Michael\Documents\ETS2MP ) If you understand what the -homedir fuction does, feel welcome to change it, if you are worried or don't know what to do, just leave it as it is

 

Solution 3:

1. Going into the 'Set Launch Options' in the ETS2 and putting in this command:
-homedir g:\'
' being the name of the folder being created (you can change ' to whatever folder name you want)
2. Set g to whatever drive you have the game installed on. Launch the game. Shut it off. go to Documents\Euro Truck Simulator 2 and copy everything. Now go to g drive, or whatever you set it as, open the folder '
3. There will be a Euro Truck Simulator 2 folder in there, paste everything from the documents folder in there.
4. Now run the game, your save should be there, and hopefully it will run better.

 

The reason for this seems to be, if the game and the save file locations are on different hard drives, like mine were. Saves were in Documents/ folder on my C Drive and my game was installed on my G drive. If the saves are located on the same hard drive, things just run smoother. There are a lot of files being written to that folder in Documents it seems besides saves, so it's best if everything is on the same hard drive

Link to comment
Share on other sites

  • 0

Hello
My problem is not solve yet, but i think this will never be solved. so you can close this :(

                                                                 2

                                                                                                                          

                                                                              

 

 

Link to comment
Share on other sites

  • 0

Hello There!

 

Your topic has been inactive for 3 days since the last reply. Because of inactivity, i will have to move  this topic to Inactive Topics. :(

 

If you still have any questions about this; feel free to DM me or our support team members, we  will open this again. ^_^

 

Thanks for all participation!
Thank you for your understanding!

 

//Locked and Moved to Inactive

Kind Regards,
96AV

TruckersMP Staff

 

“The best way to predict your future is to create it.”

 

 

Link to comment
Share on other sites

  • 0
  • Senior Translation Manager

Hello @BubbleMuscles,

I am going to move this topic to Unsolved, because it has been still inactive for  2 days.

 

Do not hesitate to contact us again by creating another topic or a support ticket, if you'll need further help.

 

//Moved to Unsolved

Kind Regards,
InvisibleRaptor

TruckersMP

1195119105_role_SeniorTranslationManager


TruckersMP Rules | Support Ticket | Knowledge Base System | Apply for staff

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.