Jump to content
  • 0
Sindre1991

Micro stutters/laggs

Question

First things first, my speccs:

 

GPU: 1050 ti
cpu: i7

installed on ssd (truckersmp and ets2 / 140gb of free space on it ;) )

16gb ram

windows 10

 

 

My Problem looks like this:

If I start ETS2 in singleplayer mode, I can play on highest resolution and shit without laggs or micro stutters BUT if I try to play it on truckersmp multiplayer i get 1sec lagg spikes every 30secs to 1 minute. It has nothing to do with autosave, i already checked that. It has nothing to do with my settings cause it works in singleplayer. I checked if it happens on crowded places, it happens in non-crowded places, too. I checked if it has something to do with players coming into my area. That isn't the problem, too.
 

 This guy had the same problem as me so I tried everything mentioned in this topic, nothing worked.

I think it should have something to do with the truckersmp client but i don't know what ^^ pls help ^^

 

Kind regards

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

hello

have your problem been solved

if not,Follow these guides:

Solution 1:

The other way is to try and Clear your computer cache which can be done from CCleaner or Clean Master for PC 

I personally reccomend Clean Master because using it from last 2 years and works perfectly :but ofcourse either of them does the job of clearing cache from your computer and other programs

 

Solution 2:

If that didn't work too you can try Cleaning up your C: Disk by the following steps

Step 1:

airomHK.png

Step 2:

hQH6HeU.png

Step 3: After clicking Disk Cleanup wait for the system to collect junk and tell you via another popup box

Step 4: Tick Mark everything once it shows that this much junk lies , Their will be several like Offline website data,Temprorary files so yeah you can Tick all and Click OK button and let the cleaning happen after that Restart your PC and wait for it to reach idling speed.

 

Solution 3:

1.Log in on the MP

2.Press your Tab button -> go to Settings

3.General -> Development Logging -> Disable

4.Drivers animation -> Disable

5.After you did that just click on Apply and ok -> Restart your Game

 

in addition

you also can read this topic

 

Best Regards

Soul Knight:)

Share this post


Link to post
Share on other sites
  • 0

Hello

 

I recommend you to verify your game files. Go to steam》right click on ets2》properties》local files》verify local files. This is a method to check if your game files are still corrrct. If they are not, steam will automaticly fix them. If this didn't work and everything else above me didn't work either, reinstall truckersmp.

 

Good luck &kind regards

 

Prxnlge

Share this post


Link to post
Share on other sites
  • 0

Hello,

  • Verify game cache

  • Delete garages, drivers.

  • Load other save game.

  • Make new profile.

  • Make sure you have the latest .Net Framework (4.7) & DirectX & Microsoft Visual C++ 2015 and use CCleaner to remove temporary files and obsolete registry paths.

  • Update your graphic card driver.

  • Pull down your graphics settings.

  • Take care not to play in busy areas.

  • If your Game is freezing for a long period it is because the mod Is attempting to its game time with the core game time. (SP & MP times are quite different)!

  • Go in company manager (this may be a pain) and fire all of your drivers first. 

  • Save your progress then completely close the game

  • Go into your Euro Truck Simulator 2 documents folders and select/highlight the your last profile (look at last modified) then with it highlighted hit the delete button.  (Again I know it could be a pain)

  • In addition this video will be helper

  • Also you can get support here by creating a ticket 

  • Browse this topics:

  • I would also recommend you to apply them as well: 

g8a452.jpg

9oy94Q.jpg

Share this post


Link to post
Share on other sites
  • 0

I already deleted everything that had to do with ETS and Truckersmp and reinstalled it. I did everything you guys mentioned above. I really think it's something wrong with the truckersmp cause everything works perfectly fine in singleplayer. So I don't really think that the problem is my pc itself, I think it's a problem created by Truckersmp client. It definately isn't my FPS cause in Singleplayer i get up to 100 fps without these laggs and on truckersmp i reach like 70 fps on ultra settings in crowded places (with laggs).

It already does start lagging in the Truckersmp login screen so FPS really shouldn't be the problem.

Share this post


Link to post
Share on other sites
  • 0

Hello :)

While you are playing do you have the charger connected to your PC? It's really critical to be connected because the machine will down clock to reserve battery life so you won't get maximum performance.

 

Secondly have you checked the clocks and temperature in Gaming Center while you are playing?

ROG_Gaming_Center.PNG

 

Last, under power options (you will find that in battery properties) have you checked High Performance?

 

oG_lrOVmRvmJ8uBf0uw08g.png

 

Another solution

1. Going into the 'Set Launch Options' in the ETS2 and putting in this command:
-homedir g:\'
' being the name of the folder being created (you can change ' to whatever folder name you want)
2. Set g to whatever drive you have the game installed on. Launch the game. Shut it off. go to Documents\Euro Truck Simulator 2 and copy everything. Now go to g drive, or whatever you set it as, open the folder '
3. There will be a Euro Truck Simulator 2 folder in there, paste everything from the documents folder in there.
4. Now run the game, your save should be there, and hopefully it will run better.

 

The reason for this seems to be, if the game and the save file locations are on different hard drives, like mine were. Saves were in Documents/ folder on my C Drive and my game was installed on my G drive. If the saves are located on the same hard drive, things just run smoother. There are a lot of files being written to that folder in Documents it seems besides saves, so it's best if everything is on the same hard drive

Share this post


Link to post
Share on other sites
  • 0

So I tried your solution with the "homedir" but sadly it didn't work out, too. temperatures and clocking seems alright. At least there is nothing i could be worried about. 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...