Jump to content
  • 0
Sign in to follow this  
luka33

Problem with DLC

Question

I need help with DLC I bought almost 3 new DLC and when I get into TruckerMP impossible to load the last saved because it throws that DLC is not Installed but in fact they are installed and when you come in the Single Play wants to work all reinstal I TruckersMP i tried it or not I have no way to do a total of 5 2 DLC we work and this new three hundred I bought almost will not work not only in the single Play wants to do.

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
Guest CrackPrewier

Hello,

Steps to be follow on the steam;
1-)log in to your steam account and enter your profile, click on the ''Edit Profile'' section.
steam_v1.jpg

 

2-)My Privacy Settings>PUBLIC Game Details>PUBLIC.You can get help from the image below.
steamsettings.png
 

Finally,

Steps to be follow on the website;

Click on ''Linked games / DLC'' tab and click on ''Check Games'' button below. https://truckersmp.com/profile/settings/redirect/dlc

5.jpg

 

 

 

Share this post


Link to post
Share on other sites
  • 0

HELLO

Please try and uninstall the affected DLC and install it again to try and fix this problem.

 

1. Open steam, go to library and right click on ETS2. Then click properties. https://prnt.sc/gkc5m1

2. Click the DLC tab and un-check all the DLCs which don't work https://prnt.sc/gkc5m1

3. Wait for them to uninstall then check the boxes again for them to install again

4. Wait for them to install again. 

5. Open ETS2 and check that all DLCs work

 

If this doesnt work then then verify your file integrity.

 

1. Follow up to step [2] in the above list but click "Local Files" tab

2. Click "Verify file integrity" 

3. Wait for steam to verify

4. Open the game and test DLCs.

(verify your DLCs from here https://truckersmp.com/profile/settings/redirect/dlc)

Remember your steam profile is set to Public (Steam profile -> Edit profile -> My privacy settings, and make sure that both My profile and Game details are set to Public.)

 

Also you can try uninstall the launcher and install-ed again  

1. Go to This Computer folder - Program Files - TruckersMP

2. Open folder ,which have a name TruckersMP Launcher

3. Next ,there is uninstall , so you click on it  Here is photo : https://imgur.com/a/J3cCiGh

4. If you have it done ,then you can go to Documents-ETS 2 MP and ATS MP folders deleted.

5. You have it ? 

6. So you can go to Webside TruckersMP  - truckersmp.com

7. As next you can downloaded a multiplayer version again . Link is here : https://truckersmp.com/download

 

in addition

you also can read this topic

 

 

Best Regards

Soul Knight:)

  • Confused 1

Share this post


Link to post
Share on other sites
  • 0

Firstly hello,

Most probably you installed and enabled a mod, then saved the game and quit. Afterwards you disabled the mod and tried to load the game.

It depends on the mod, but many save games can be loaded without the mod, game will just abandon the current delivery with no penalties and load fine. (unless you are driving a moded truck or in some map like Promods)

 

Please try to do this:

  • Remove the DLCs and try downloading again
  • Download a different save file by change the save file you are using
  • Alternatively you can re-enable the mod and the game should load without errors.

I hope it works. Good luck with,

Best regards.

 

 

Share this post


Link to post
Share on other sites
  • 0
Guest Square Fenix

Updated : 

reply back if issue is fixed //

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...