Jump to content
  • 0
Sign in to follow this  
X_KacpeR_X

version

Question

4 answers to this question

Recommended Posts

  • 0

It seems your game has updated to 1.28, which is currently incompatible with TruckersMP. Please take a look at the following topic for help on downgrading to the correct 1.27 version -

Hope this helped, best of luck.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...