Jump to content
  • 0
rebootdancer

ATS:MP Only doing 20-30fps?

Question

I normally run the game around 60-100FPS even in MP. Dropping in towns ETC. But since the last update I have been doing 30 FPS or lower max. Even in the pause menu to access the world map. Is this a known issue? 

-PC specs-
i5-4460 3.2ghz
GTX 750Ti 2gb
16gb ddr3

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 1

Make sure that you have both,

 

.NET Framework

https://www.microsoft.com/en-us/download/details.aspx?id=53344

 

C++ VisualC 2015 

https://www.microsoft.com/en-gb/download/details.aspx?id=48145

 

Also, if you haven't already I would suggest that you uninstall TruckersMP and also delete the ATS folder in documents then reinstall but open the exe as an admin and then one installed the shortcut as an admin too.

 

To make sure that it is using DirectX, once reinstalled open ETS2 SP and choose DirectX 64bit, you will need to play a job or something and then go back and open the MP mod and see if there is any difference in performance.

Share this post


Link to post
Share on other sites
  • 0

Is this an issue with both single player and multiplayer?

 

As far as I know there hasn't been any report FPS problems with regard to any updates, (a support or admin might respond differently though) does this update that you are talking about pertain to TruckersMP or ATS?

 

This guide actually pertains to ETS 2 but may work for ATS as well.

 

Hi,

 

On the login screen at the start of booting up the multiplayer mod there is a wrench icon at the top left, click on that.

 

You will then be presented with the window below, if you click on Graphics you will be able to disable things that can cause performance loss.

 

The main ones (indicated by arrows) are the shadows and the draw distance, you can edit these here to your liking.

 

The bottom image, (the first tab) General, has some more things that you can disable to increase performance, as you can see the ones that increase performance are circled in red.

 

I hope that this helps you.

 

To note, disabling Seasonal effects can also increase performance.

 

Sorry about the poor paint skills,

 

37C5K7o.jpg

Many thanks,

Share this post


Link to post
Share on other sites
  • 0
19 hours ago, 3567- said:

Is this an issue with both single player and multiplayer?

 

As far as I know there hasn't been any report FPS problems with regard to any updates, (a support or admin might respond differently though) does this update that you are talking about pertain to TruckersMP or ATS?

 

This guide actually pertains to ETS 2 but may work for ATS as well.

 

Hi,

 

On the login screen at the start of booting up the multiplayer mod there is a wrench icon at the top left, click on that.

 

You will then be presented with the window below, if you click on Graphics you will be able to disable things that can cause performance loss.

 

The main ones (indicated by arrows) are the shadows and the draw distance, you can edit these here to your liking.

 

The bottom image, (the first tab) General, has some more things that you can disable to increase performance, as you can see the ones that increase performance are circled in red.

 

I hope that this helps you.

 

To note, disabling Seasonal effects can also increase performance.

 

Sorry about the poor paint skills,

 

37C5K7o.jpg

Many thanks,

The thing is, it is just Multiplayer. Single player it runs fine and was running fine until the last update for ATS. Single player I run at a solid 60 FPS (limited) and in multiplayer it doesn't even reach 30. I appreciate the help but that isn't the current problem. Even in the pause menu it's laggy and when I move my mouse it skips around. 

Share this post


Link to post
Share on other sites
  • 0
11 hours ago, 3567- said:

Make sure that you have both,

 

.NET Framework

https://www.microsoft.com/en-us/download/details.aspx?id=53344

 

C++ VisualC 2015 

https://www.microsoft.com/en-gb/download/details.aspx?id=48145

 

Also, if you haven't already I would suggest that you uninstall TruckersMP and also delete the ATS folder in documents then reinstall but open the exe as an admin and then one installed the shortcut as an admin too.

 

To make sure that it is using DirectX, once reinstalled open ETS2 SP and choose DirectX 64bit, you will need to play a job or something and then go back and open the MP mod and see if there is any difference in performance.

That helped it for the most part. Not up to single player standards but with the game rendering in so many other "players" and not AI I know why I am still low of FPS. Not 30 anymore but up to around 45-50 when sitting in Elko. Which means when I am on the highway it should be around 50. Moderator can mark this as solved for now. If it continues I will create a new post with either screenshots or video proof of the lag. 

  • Upvote 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...