Jump to content
  • 0

Unable to update TruckersMP.



I am aware ETS2 had a small update today. However, whenever I click on the TruckersMP icon on my desktop this little window pops up...




When I click ok to retry, the window just pops up again. When I click cancel, I am brought to the download link of the mod on the website. I follow the instructions and installed it like I had done before in the past, However, when I try to launch TruckersMP this time, the same window pops up again.


Any help/solution? :P

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • -1

Hello @JorMallester,


I am not quite sure whether anybody replyed before, but try to run the launcher as an administrator because this can fix a lot of issues.


Additionally, I will post you a link to a topic with known errors of the launcher:


If you didn't find your solution yet or don't know how to procced further, please contact the official TruckersMP support who will help you:




Thanks for reading, feedback is always more than welcome :)


Kind regards ;)

Link to comment
Share on other sites

  • -1

Hey, I had the same problem but now was solved.

I made this:

1. Restart PC

2. Start Steam

3. Right Click on the Launcher and "Run As Administrator"


And voila, now run... (I think that steps 1 and 2 do not need)

Good luck!! :)

Link to comment
Share on other sites

  • -1

Hello guys and thank you for all the responses! I am very sorry for not responding for a few days but my problem is indeed now solved. It was simply a matter of making sure eurotrucks2.exe was not running. For some reason it was and this caused the issue.


Thank you all very much for the help, it was much appreciated! :)

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.