Jump to content
  • 0
Koolboy

I am lagging - how could I fix it?

Question

Hello everyone,

 

I have quite a good internet connection (about 40.000 - 50.000 Kbit/s download) and always pingrates of 30-50 ms. But I am still lagging in other player's games. I often drive together with a friend and he never comes closer than 150m, because he's afraid that I will lag and we could cause a crash. There are 2 types of laggs for me:

1. My game "freezes for about 2 seconds. On my friend's game I stand completely still and after those 2 seconds I start moving again.

2. I drive completely normal, but on the screen of my friend I am lagging back- and forwards, sometimes even sidewards. Personally, I don't notice anything of that.

 

So, are there other players experiencing the same problems? How could I fix that? It makes driving in convoys impossible and endangers other players too.

 

Best regards

 

 

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

Hi,
I had the same problem with the autosave lag. It happened to me because I changed the setting "uset g_save_format" from 1 to 3 to sync my jobs with www.ets2sync.com/.

The solution in my case was:

Go to your documents folder

Open Euro Truck Simulator 2 folder

Open config.cfg with the editor

Change the line

uset g_save_format "3"

to

uset g_save_format "1"
Now save your document and try playing again, lag should be banned :)

Edited by immortal766
Removed quote

Share this post


Link to post
Share on other sites
  • 1

I've had that same problem earlier today, but after doing some research, I found out that if I fire all of my drivers and sell all of my trucks that the freezes don't even occur anymore, keep in mind I'm still testing it out. When the game "freezes", it may or may not be caused by your game autosaving. As for number 2, it can just be caused by desync and/or lag server-side. 

 

Here's the link to the clip I recorded when my game froze due to autosave, just to see if you have the same problem: http://plays.tv/video/57a4e869ebae4ca26b/ets2-autosave-freeze?from=user

Share this post


Link to post
Share on other sites
  • 0

What are your PC specifications?

 

Are you using wireless or LAN?

Edited by JeKnYan

Share this post


Link to post
Share on other sites
  • 0
11 hours ago, Chris.D said:

I've had that same problem earlier today, but after doing some research, I found out that if I fire all of my drivers and sell all of my trucks that the freezes don't even occur anymore, keep in mind I'm still testing it out. When the game "freezes", it may or may not be caused by your game autosaving. As for number 2, it can just be caused by desync and/or lag server-side. 

 

Here's the link to the clip I recorded when my game froze due to autosave, just to see if you have the same problem: http://plays.tv/video/57a4e869ebae4ca26b/ets2-autosave-freeze?from=user

 

I will test that later, thanks for your help!

 

EDIT: Yup, my type of freeze is exactly the same. So I'll have to try your tips out. Hopefully it'll work for me, too.

 

Sorry, I totally forgot to write my specs. I am not 100% sure about them, but as soon as I get back home I'll post edit the correct and missing

parts. 

 

Motherboard: BioStar H61MH

CPU: i3-211 @3.1 GHz

GPU: Zotac GTX 500 Ti AMP!

RAM: 8 GB 

OS: Win 10, Professional 64Bit

HDD: 1 GB 

 

@JeKnYan

I am using LAN.

 

Share this post


Link to post
Share on other sites
  • 0

Your specs are quite low! Lower your graphics as much as possible and avoid high population area, ie. Rotterdam. 

 

Something you could try to see if your CPU is maxed out, open the task manager, open it with the performance tab, launch your game and wait till the problems occur, quickly alt-tab and look at the graphic? I suspect that the CPU usage will be close to 100%

Share this post


Link to post
Share on other sites
  • 0

Sadly there isn't an option to disable autosaving. The method I mentioned earlier is possibly the only fix. Just to be clear, I only have 1 truck and no driver's hired so there is basically nothing for the game to autosave.

Share this post


Link to post
Share on other sites
  • 0

Well I left only 2 other trucks I like to drive (owning an Mercedes, Volvo and Scania) but no other drivers. But at least it's a lot better than before.

What about the other type of lag? (desyncs etc) Are they somehow fixable?

Share this post


Link to post
Share on other sites
  • 0

Just for kicks:

 

Try opening the control panel in W10 going to Power Options and setting it to "High Performance" (located under the "Show Additional Plans" button).

 

Nvidia also has a similar option for graphics cards:

Open the Nvidia Control Panel (not GeForce Experience), navigate to "Manage 3D Settings" and then find "Power Management Mode" under the GLOBAL settings. If you haven't already guessed, set the card to "Prefer Maximum Performance."

 

I would also mention that I haven't experienced this using a SSD. 

Share this post


Link to post
Share on other sites
  • 0

Hi @Koolboy,

 

Please can you let us know if you're still experiencing these issues?

 

If not, please mark the best solution by clicking on the grey and white tick button on the users post.

 

As a side note, there is currently some desync on the servers at the moment that should be fixed in the next TMP update.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×