Jump to content
  • 0

Need help with "fatal error" once trying to launch TruckersMP.



4 answers to this question

Recommended Posts

  • 0

Hello @Rondo994,

Thank you for using the forum for any queries you may have. 


The error you are receiving is due to the fact that you are possibly using an outdated version of ETS2. If you could please follow the following steps, and it should fix your problem: 


1. Head over to steam

2. Open your Library

3. Euro Truck Simulator 2

4. Open Properties...

5. Head over to Betas

=> For ETS2 select: None


If you are having trouble doing this you can have a look at this video in order to help you. 


Please tell us if this has solved your problem or you would like some further assistance, so we can move this topic to its correct place. 


Best Regards, 


Link to comment
Share on other sites

  • 0

Hello @Rondo994,

We're glad to hear that your problem was solved! If you run into any issues in the future please don't hesitate to reach out again.


I will now be locking this topic and moving it to Solved topics.




TruckersMP Support


// Locked & moved to Solved


Pries Logistics | Discord | Website | Insta | Twitter | Facebook

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.