Jump to content
  • 0

Game crashing after delivery.


ChapaLV
 Share

Question

Good evening.

I've explored through all of google, multiple topics on this forums and other places where a few solutions have been given.

I've tried re-installing both ETS2 and TruckersMP, verifying cache, changing ETS to both OpenGL and DirectX 12 64-Bit, tried running ETS2 on windowed mode, opening TruckersMP as administrator but so far absolutely nothing has worked. While re-installing ETS2 and TruckersMP, before doing that I deleted every folder so both installs would be as clean as possible.

But nothing has helped, every delivery, no matter the cargo, the truck or the distance, I come to the destination, choose to skip the parking, press the button to fully finish the delivery and the game still crashes with no error window.

I have no mods installed!

I have added game.crash.txt if that helps in any way.

game.crash.txt

Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 1
14 minutes ago, ChapaLV said:

Hello.

Yes, I've already tried the following with no successful result:

Verifying game integrity (even after re-installing ETS2)

Set ETS2 to run on DirectX 12 64-bits and running TruckersMP as administrator.

And re-installing TruckersMP after completely deleting every folder of it also doesn't help.

Did you try create another profile in ETS2? Because your profile can be corupted, so it can be a problem aswell.

 

If not, please create a new one, and then try to take a some job.

 

Have you a same problem in Singleplayer? 

 

I'm awaiting your respond! 

 

Regards, 

RedWolf

  • Love it! 1

Streamer on: https://www.twitch.tv/redwolf_cz

Languages: 🇬🇧 🇨🇿 I 🇸🇰 I Discord: RedWolf [CZ]#0886

Forum Role: Veteran Driver II  (ETS 2: +4,600 hours)

HR Staff of GB I Player of TruckersMP Community

 

2117614355_role_VeteranII(1).png.a9bb8eb

 

Link to comment
Share on other sites

  • 0

Hello there! 🙂 

 

Firstly, welcome on TruckersMP Forum :tmp:

 

For this problem, please follow these steps: 

 

Solution 1: 

 

Have you tried verify your game ?

> Go to Steam Library

> Right click Euro Truck Simulator 2

> Properties

> Local Files

> Verify Integrity of Game Files

Wait until the game files are verified and try whether the error still occurs.

 

Solution 2: 

 

You should start TruckersMP as admin. This is really important.

Also try to start TruckersMP with DirectX (64)

 

How to do that?:

> Go to your steam App
> Go to library
> Go to ETS 2 / ATS
> Click "Play" 
> Choose "Launch with DirectX (64-bit). Make sure you chose 64 bit.
> Start ETS 2
> Choose your profile and press "drive"
> Close ETS 2
> Start TruckersMP as admin. TruckersMP will start with DirectX for all time. Except you change it again.

 

 

If it did not work, then I recommend you re-install TMP Launcher with following this guide: 

 

 

Press the Windows Key + R (Win+R) on your keyboard
Enter "%programdata%" and press Enter (without the quotes)
Find the folder "TruckersMP" and delete that folder.
Go to documents and delete this folders called (ETS2MP, ATSMP) 
Navigate to C:\Program Files\ and delete the folder named "TruckersMP Launcher"
Go to our website and re-download and install the Launcher with admin privileges https://truckersmp.com/download/ 
Open The Launcher with admin privileges and click "Install Available Updates"

 

 

 

Hope, some of sollutions will help you with your problem! 

 

 

Good luck!

 

I am looking forward for your reaply ❤️ 

 

Regards,

RedWolf

 

Streamer on: https://www.twitch.tv/redwolf_cz

Languages: 🇬🇧 🇨🇿 I 🇸🇰 I Discord: RedWolf [CZ]#0886

Forum Role: Veteran Driver II  (ETS 2: +4,600 hours)

HR Staff of GB I Player of TruckersMP Community

 

2117614355_role_VeteranII(1).png.a9bb8eb

 

Link to comment
Share on other sites

  • 0

Hello there,

 

Did you get the answer you were looking for with the answers given above?
Your confirmation of the status of your issue/question helps us keep the forum always organized!

 

Kind Regards,

Krisi.

TruckersMP - Support & Add-On Team

Wolves™ | Content Creator

----------------------------------------------------------------------------------------------

🇬🇧 Rules Support Feedback | Guides Ban Appeal 🇬🇧

🇭🇺 Szabályzat Támogatás | Visszajelzés | Tudásbázis Fellebbezés 🇭🇺

----------------------------------------------------------------------------------------------

TruckersMP

c72Zew3.png

----------------------------------------------------------------------------------------------

Link to comment
Share on other sites

  • 0

Hello.

Yes, I've already tried the following with no successful result:

Verifying game integrity (even after re-installing ETS2)

Set ETS2 to run on DirectX 12 64-bits and running TruckersMP as administrator.

And re-installing TruckersMP after completely deleting every folder of it also doesn't help.

Link to comment
Share on other sites

  • 0
Posted (edited)

Another thing you could try is, if you have MSi Afterburner installed, closing all the Programmes related to MSi Afterburner via the Task Manager. To open the task manager you have to press "Ctrl+Alt+Del" and choose "Task Manager". There you have to look out for the main MSi Afterburner Application and the RTSS (RivaTunerStatisticsServer) Servers and then close them all. Try that combined with running it in administrator mode please and see if it fixes the problem.

 

I hope I could help out with this.

Edited by maksch
Removed some parts that have been mentioned before.
Link to comment
Share on other sites

  • 0
Posted (edited)
1 hour ago, [Mega Trans] CrystaL said:

Another thing you could try is, if you have MSi Afterburner installed, closing all the Programmes related to MSi Afterburner via the Task Manager. To open the task manager you have to press "Ctrl+Alt+Del" and choose "Task Manager". There you have to look out for the main MSi Afterburner Application and the RTSS (RivaTunerStatisticsServer) Servers and then close them all. Try that combined with running it in administrator mode please and see if it fixes the problem.

 

I hope I could help out with this.

Yes, I read this somewhere before, checked if I have any MSI Afterburner and RTSS related proccesses running and I had none.

Once again tried running OpenGL. But now tested it on SP, not TruckersMP. Game still crashed. On both World of Trucks cargo and normal cargo.

Edited by ChapaLV
Link to comment
Share on other sites

  • 0

UPDATE!

Might have found a fix.

Checked my game_logs and the last thing the game did before crashing was recording the delivery with LogIt. Since I installed it a long time ago and it never fully worked, I ditched it and was sure I didn't have it anymore. Turns out, it doesn't delete itself even after fully re-installing ETS2. Now that I found its folder and deleted it, I tested ETS2 SP again and did 2 successful deliveries without a crash. So if anyone else is experiencing this problem, check if you have LogIt installed and delete it. I don't remember exactly for which website it was used but it never really worked and seems like it's a big issue for ETS2 right now.

Link to comment
Share on other sites

  • 0

Hello there, 🙂 

 

Since you found a solution, I will go ahead and move this topic to solve topics. 

If you have anymore issue in the future, feel free to contact us again 

 

Sincerely,
Beenz.

TruckersMP - Support 

 

//Locked and moved to Solved Topics 
 

    TruckersMP - Support     

           image.png.3f4da8ebf814e85c1d1af8ae0848ad53.png               

Language: English

  Support System | Knowledge Base | TruckersMP Rules | Feedback System

 Remember stay positive ❤️

 

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.