Jump to content

Jacrispyxd

Veteran Driver VII
  • Posts

    119
  • Joined

  • Last visited

9 Followers

About Jacrispyxd

  • Birthday 05/27/2003

Profile Information

  • Gender
    Not Telling
  • Location
    United States, Missouri
  • Interests
    things...... I sexuauly identify as a oreo poptart
  • Preferred Trucks
    Scania
  • American Garage Location
    Nevada: Elko
  • EU Garage Location
    Germany: Düsseldorf
  • Known languages
    every laungauge in the universe (totally not google transleate)

TruckersMP Information

  • VTC Name
    Alpha Logistics

Recent Profile Visitors

20426 profile views

Jacrispyxd's Achievements

78

Reputation

1

Community Answers

Single Status Update

See all updates by Jacrispyxd

  1. yoo whats crakin so I need some help I'm trying to launch the game through trukers mp and it says unsupported client version how do I downgrade?

    1. KhaosHammer

      KhaosHammer

      Downgrade your ETS to the version "temporary_1_30 - 1.30.1.6 for incompatible mods""temporary_1_30 - 1.30.1.6 for incompatible mods" as shown below :

       

      671d85ddc2.png

    2. Show next comments  3 more
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.