Jump to content
  • 0

Connection Error - Retry?



6 answers to this question

Recommended Posts

  • 2

Hello @ploysi ,


If core_ets2mp.dll is not working for whatever reason you can get the above error. Usually it appears when you try to update the multiplayer launcher with the game open.


First, check if ETS2 process is running. If so, end it and try again.

If this doesn't help delete core_ets2mp.dll, re-open launcher and re-download file. Path: C:\ProgramData\TruckersMP


I hope your problem is solved with this solutions  :) 



Best regards,


Dominik (iFlufy)

TruckersMP Support 



  • Upvote 1
Link to comment
Share on other sites

  • 0


Solution 1:

Goto C:\ProgramData\TruckersMP
Delete both core_ets2mp.dll  files
Start Truckersmp launcher as administrator and click on install the files.

Solution 2:

Press the Windows Key + R (Win+R) on your keyboard
Enter "%programdata%" and press Enter (without the quotes)
Find the folder "TruckersMP" and delete that folder.
Navigate to C:\Program Files\ and delete the folder named "TruckersMP Launcher"
Go to our website and re-download and install the Launcher with admin privileges https://truckersmp.com/download/
Open The Launcher with admin privileges and click "Install Available Updates



Link to comment
Share on other sites

  • 0

Hello @ploysi :)

Has your problem been solved because you are currently in game now ?


If not, can you try these:

And are you sure your PC are in the latest version of the .Net Framework? You probably get this error because the older versions of the .Net Framework cannot match C++ credits.

Important: If the .net framework is lower than the version .Net Framework 4. Firslty, download the 4th version and then install the 4.6 version. (If you have already 4. version or upper versions, download the 4.6 version directly)


Also try this:

Clean your temp files with CCleaner

Check your temp files path and make sure it's located at C:\Users\name\AppData\Local\Microsoft\Windows\INetCache

If you don't have "INetCache" folder make a new folder and name it "temp" and then open the Windows temp settings and choose the new path.


And try this:

> Download Ultrasurf.
> Run Ultrasurf.
> Open TruckersMP in Administrator Mode.
> Install the available updates (only the first run with Ultrasurf), wait for it to finish and Launch button appears.
> Exit Ultrasurf


Also read these topics:


Link to comment
Share on other sites

  • 0

Hello @ploysi,

This topic has been inactive for 3 days and because of that i'll move it to Inactive Section.
Feel free to DM me or someone else from support team if you still need help from us. We will open this topic again if needed.

Thanks for understanding!

//Locked and Moved to Inactive

Link to comment
Share on other sites

  • 0


because of this topic has been inactive for 2 more days , I'll have to move this topic to Unsloved Topics.
If you still need any help, feel free to create a new topic or contact us directly by submitting a support ticket: https://www.truckersmp.com/support

//Locked and Moved to Unsolved

Kind regards,


Retired Manager



Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.