Jump to content
  • 0

90km/h problem

Go to solution Solved by Elsassisch_Trucker [FR],


7 answers to this question

Recommended Posts

  • 0

Hey there,


You need to do both of the following:

1-) Disable the speed limiter in your ETS2/ATS settings (Book Here)
2-) Disable the speed limiter in the TruckersMP tab menu (Book Here)
3-) You could join a server that has the speed limiter disabled completely after doing steps 1 & 2. (Optional)
4-) Steps 1 & 2 on a server with a speed limiter enabled it will limit you to 110kmh/68mph
5-) Any speed on External Contracts cannot go more than 90 km/h. 
* To go more than 90 km/h have to remove the limiter and taking those not speed game on External Contracts.

  • Thanks 1







Link to post
Share on other sites
  • 0

Hey there,


we are glad to hear that your Problem has been solved! Thank you all for the helpful answers <3


//locked and moved to Solved





Support Manager



contact us here: https://truckersmp.com/support/ticket/create

Link to post
Share on other sites
This topic is now closed to further replies.
  • Create New...