Jump to content
  • 0
V.Marius

Conection error.!

Question

5 answers to this question

Recommended Posts

  • 2

Hello @VMarius240,

 

please run the launcher as an administrator and make sure that the process eurotrucks2.exe is not running. Also, try to delete the following file manually [C:/ProgramData/TruckersMP/core_ets2mp.dll].

 
I am quite sure that this will be solving your issue. However, if it does not, check out the following guides:

 

 

 

Kind regards ;)

Share this post


Link to post
Share on other sites
  • 0

Well, @VMarius240, it is quite unfortunate to hear that.

However, there are still some solutions you should take into consideration before bothering to contact the TruckersMP support.

 

Because it is just easier as well as more convenient, I will just post bullet points down below, so make sure you follow and read them thoroughly:

 

  • Start a command line as an administrator (press Windows key and type "cmd", right click run as administrator), then, run the command sfc /scannow
  Hide contents

KqUJPnV.png

 
 
 
  • After having done so wait and restart your computer.
  • Run a single game in x64 DirectX mode
  Hide contents

Lr5LAOZ.png

 
 
 
 
 
 
 

 

  • Drive a short distance, exit the game and start multiplayer again. (Credits to ResTed)
  • Uninstall the TruckersMP launcher and download it again (https://truckersmp.com/download)
  • Verify the integrity of the game cache by opening steam, right-clicking ETS2/ATS => Properties => Local Files => "verify integrity of game cache"
  Hide contents

BSItvL0.png

 
 
 
 
 
 
 
 

 

  • Check for possible BETAs by right-clicking ETS2/ATS => Properties => BETAS => "NONE - Opt out of all beta programs"
  Hide contents

fjLc7Yj.png

 
 
 
 
 
 
 
 

 

  • It could possibly sometimes be caused due to the install path of the TruckersMP client being wrong during installation. Take a look at this thread here:
Spoiler

 

 

 

 

If those steps above do not work, proceed further to this:

 

1. Uninstall TruckersMP client

2. Head to your "documents" folder in Windows

3. Delete the "ATSMP/ETS2MP" folder ONLY!

4. Reinstall TruckersMP Client

 

Additionally, try to run a sfc /scannow command in DOS then restart your computer and try again (see: https://www.lifewire.com/how-to-use-sfc-scannow-to-repair-windows-system-files-2626161 for further information).

 

1. Press the Windows Key + R (Win+R) on your keyboard

2. Enter "%programdata%" and press Enter (without the quotes)

3. Find the folder "TruckersMP" and delete that folder.

4. Navigate to "C:\Program Files\" and delete the folder named "TruckersMP Launcher"

5.Go to the TruckersMP homepage and re-download + install the Launcher with admin privileges (homepage: https://truckersmp.com/download/).

 

Also, install these two programs:

 

.NET Framework 4.6.2

https://www.microsoft.com/en-us/download/details.aspx?id=53344

 

VisualC++ 2015

https://www.microsoft.com/en-us/download/details.aspx?id=48145

 

[Credits @Sentinel_]

 

 

However, if nothing has helped yet, you should consider contacting the official support by submitting a ticket: https://support.truckersmp.com/index.php?a=add

 

 

Regards ;)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...