Jump to content
  • 0

Multiplayer opens as Single Player when running as Administrator

Matt #CarLadMatt


I have tried updating the games from the Truckers.MP website. However when I try to run both as administrator it runs as Single Player. I have No Betas Active on my steam versions of ETS2 and ATS. This update has worked for everyone else except me for some reason.


I have been looking forward to this update coming out and I would like to find out why it isn't working!

Please help. Thanks


@El1teZombiezHD @MrCreeper


Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Hi. Im guessing you are right clicking and then running as admin?


Try doing this:


1) Go to your TruckersMP install directory.

2) Right Click "launcher_ets2mp.exe" and click "Properties"

3) Click on the "Compatibility" tab

4) And then select "Run this program as Administrator"

5) Start the game from the .exe or shortcut on your desktop.

Do NOT try launching multiplayer from Steam (as a non steam game), this may not work



Kind Regards,


[TruckersMP Retired Team Member (Ex-Game Moderator)]



If you are replying to me, please @mention me (@El1teZombiezHD ) or quote my message otherwise I may not respond

Link to comment
Share on other sites

  • 0
Guest Tom Howard



If running Steam as Administrator doesn't work, have you tried uninstalling and reinstalling the mod? This often fixes issues of this nature.

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.