Jump to content
  • 0
Sign in to follow this  
lilapocalyptic

Error trying to open ets2 mp

Question

Iv just downloaded both ets2 on steam and ets2 multiplayer when opening the mp I get and error message saying to play ets2 mp you need to have ets2 1.19.2.1s (steam release) how do I get the mp to work as iv tried everthing and cant 1.19.2.1s in the beta

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...