Jump to content
  • 0

I can´t join to the Server


Go to solution Solved by HelenAndio,

Question

4 answers to this question

Recommended Posts

  • 1
  • Solution

This is not a bug, it's an issue related to detecting your DLC.

 

Please go in your Steam profile -> Edit profile -> My privacy settings, and make sure that both My profile and Game details are set to Public.

 

Then go on TruckersMP website and go on Account -> Settings -> Linked Games / DLC, and click on Check DLC.

 

After those two steps, it should hopefully fix your issue with not being owner of DLC on ETS2MP.

  • True Story 1
Link to post
Share on other sites
  • 0

Hello :) 

Have you even tried to reinstall both TruckersMP and Euro Truck Simulator 2? 

And the file path from TruckersMP is installed in the correct directory?

Any DLC for ETS2 from steam should work for you in the multiplayer version. 

 

Please try and uninstall the affected DLC and install it again to try and fix this problem.

 

1. Open steam, go to library and right click on ETS2. Then click properties. https://prnt.sc/gkc5m1

2. Click the DLC tab and un-check all the DLCs which don't work https://prnt.sc/gkc5m1

3. Wait for them to uninstall then check the boxes again for them to install again

4. Wait for them to install again. 

5. Open ETS2 and check that all DLCs work

 

If this doesnt work then then verify your file integrity.

 

1. Follow up to step [2] in the above list but click "Local Files" tab

2. Click "Verify file integrity" 

3. Wait for steam to verify

4. Open the game and test DLCs.

(verify your DLCs from here https://truckersmp.com/profile/settings/redirect/dlc)

Remember your steam profile is set to Public (Steam profile -> Edit profile -> My privacy settings, and make sure that both My profile and Game details are set to Public.)

 

Also read these topics

 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...