Jump to content

Search the Community

Showing results for tags 'mango'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • News
    • Development Announcements
  • Information & Support
    • TruckersMP Rules
    • Guides
    • Help
    • Bug Reports
    • Suggestions
    • Recruitment
  • Community
    • General Discussion
    • Hot Topic
    • Discord
    • Companies
    • Community Events
    • Off Topic Discussion
    • Developer Portal
    • Unofficial tools
    • Media
  • International Community
    • Other Languages
  • Archive

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


Interests


Known languages


TruckersMP ID

 
or  

VTC Name


VTC ID

 
or  

YouTube


Plays.tv


Twitter


Twitch.tv


Hitbox.tv

Found 1 result

  1. When you read the title, i do know how to fix it and if you have the same problem, then i know how you might be able to fix it. After few updates at the past i have gotten notes about having a ,,unsupported game version,, every time update comes out. after you download the update,you still get the itsact same notification. Yes,i also fell into confusion and wondered,am i ever able to play ETS2MP? I watched one youtube video and i was advized to open steam and find ,,Euro truck simulator 2,,. Keep the arrow on the ,,Euro truck simulator title,, and right click it. After you gave done tgat, move down and open ,,properties,,.. Click ,,Betas,, and you select a version of the game ETS2 recommends you to pick. By it i mean that, after i tried to open up the game earlyer and got a notification, it advized me,which version i need to have,to open the game. (for excample ,,Euro Truck Simulator 2v. 1.25.2.2s,,) Good luck!
×
×
  • Create New...