Jump to content
C-D Intersection ×

UncleSlam

Veteran Driver III
  • Posts

    6
  • Joined

  • Last visited

About UncleSlam

Recent Profile Visitors

552 profile views

UncleSlam's Achievements

0

Reputation

  1. ^ Thanks for the reply, i don't think so too honestly. Before it worked all fine and started happening on the next day. My internet connection is fine though. No problems of loading stuff or similiar. My speed results are: ping: 45ms, down.speed: 5,76Mbps, up.speed: 0,46Mbps. The really strange thing is that the same problem happened to my friend who i played the day before it happened with so i don't really know whats goin on there
  2. every time i try to connect with europe server (or others, no matter) it fails connecting successfully and says " connection to server has been broken, restart game to connect again". got this since 4 days now and it worked fine before so what i mean by that is it happened suddenly from one day to another and i have no explanation for that. got the latest MP version of ets 2. newest update through steam. tried reinstalling MP and SP about 3 times, no change. Any help would be highly appreciated because support is not even answering
  3. oh i do not use IE too but got it installed. I got the IE version 11.0.9600.18163 i turned off this smartscreen filter already i think
  4. okay thanks for the reply, so you on win10. Is that smartscreen function or whatever on win7 too?
  5. i can't connect to any server suddenly, two days ago all worked fine. Yesterday no more. "Connecting to Europe (number)...restart game to try again". Got the latest version. no ban or similiar. Any help? Thanks in advance
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.