Jump to content

getthebackofme

Veteran Driver II
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Truck?

About getthebackofme

  • Rank
    No Cargo
  1. so i had this last year and played a bit and now when i want to play it again it says unsupported game version detected! to pl ay you need to have euro truck simualtor 2 v. 1.26.2s i went to steam properties and then the right beta still same error do not know what to do before this i had porbblems with steam_api64.dll
×
×
  • Create New...