Jump to content

Incompatible ATS/ETS2 Update

Phon

SCS have released version 1.41 for American Truck Simulator and Euro Truck Simulator 2.

 

TruckersMP currently does not support these updates. In order to continue playing TruckersMP, you will need to downgrade to the 1.40 branch.

 

Check out this article on how to downgrade your game to the working version.

Announcements



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.