Jump to content

User_4336967

Driver
 TruckersMP Profile
  • Posts

    4
  • Joined

  • Last visited

Everything posted by User_4336967

  1. I can't start TruckersMP because it tells me I have the wrong version and need 1.42.1.7 but on steam there is no 1.42.1.7 only 1.42.1 and this doesnt work what should i do?
  2. I can't connect to server 2, it keeps saying "authenticating". But Server 1 is working fine. Someone else?
  3. Hi, I installed a small mirror mod so I could see the front mirror too. Unfortunately its not working in TMP. Does someone know why?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.