Jump to content

TruckersMP Supports the latest update! (1.50.2.3)

This announcement is no longer active

Rider.

The latest versions of both ATS and ETS2 are fully supported on TruckersMP.

 

Enjoy the update, and we hope to see you out on the road!

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.