Jump to content

1.38 Support Released!


Recommended Posts

  • Replies 112
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Greetings! For two months, many of you have patiently anticipated our compatibility support for the latest versions of Euro Truck Simulator 2 and American Truck Simulator. With lots of the backend co

Support for Euro Truck Simulator 2 1.38.1.11s is now available.

Hai there,  Make sure to choose "NONE - Opt out of all beta programs" and not 1.38 when choosing the correct beta.  

Posted Images

Thanks for the updating, sadly the volvo isnt fixed yet, is an easy fix and I already explained what I found I hope it will get fixed soon.

@shak0 is the truck a volvo with sleeper cabin?

If it is that is just a missing coordinates file for the cb radio but they didnt fixed it yet sadly.

And I actually made a fix for it on this post 

 and there is the files to work with 1.38

https://drive.google.com/file/d/1yo5jBjsiS7MQ3TS1GyQGBEiqm3-Np3Gh/view?usp=sharing

and some pictures of it working.

spacer.png

 

spacer.png

spacer.png

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...