Jump to content
  • 0
Vaasan08

ETS2 TruckersMP Update??

Question

8 answers to this question

Recommended Posts

  • 0
13 minutes ago, CycloneGaming said:

The update will be ready when it's ready there is no ETA (yet). Please be patient.

I paused my game update at 80% since the update released and waiting to resume only after TruckersMP supports v3.17😞.

Share this post


Link to post
Share on other sites
  • 0

Unfortunately we don't believe the update for 1.37 will be released before the end of May. Our project management had given us confirmation of this in the public discord server previously: 

 

ooI2GN8.png 

 

This is due to the overall complexity of the 1.37 updates including the entirely new sound engine, as well as developers personal lives being affected by the current COVID-19 pandemic, so it may take some time before the update is released.

 

In the meantime, you can downgrade your game and continue to play TruckersMP by using the following guide:

 

https://truckersmp.com/knowledge-base/article/26

 

For the ProMods server you can use v2.45 to play on TruckersMP on ETS2 1.36, which can be found for download here: https://www.promods.net/compat.php.

Share this post


Link to post
Share on other sites
  • 0

Hello there!


Has your question been answered with the above given answers?

Your confirmation of the status of your issue helps us keep the forum always organized!

I await your return!


Kind Regards
Sabbi [GER]
TruckersMP Support

Share this post


Link to post
Share on other sites
  • 0
39 minutes ago, heyhococo said:

Unfortunately we don't believe the update for 1.37 will be released before the end of May. Our project management had given us confirmation of this in the public discord server previously: 

 

ooI2GN8.png 

 

This is due to the overall complexity of the 1.37 updates including the entirely new sound engine, as well as developers personal lives being affected by the current COVID-19 pandemic, so it may take some time before the update is released.

 

In the meantime, you can downgrade your game and continue to play TruckersMP by using the following guide:

 

https://truckersmp.com/knowledge-base/article/26

 

For the ProMods server you can use v2.45 to play on TruckersMP on ETS2 1.36, which can be found for download here: https://www.promods.net/compat.php.

OH Okay...😞then I'll just cancel my update...😕🙄

THANK YOU.

Share this post


Link to post
Share on other sites
  • 0
36 minutes ago, Sabbi [GER] said:

Hello there!


Has your question been answered with the above given answers?

Your confirmation of the status of your issue helps us keep the forum always organized!

I await your return!


Kind Regards
Sabbi [GER]
TruckersMP Support

YES, my question has been answered.

Share this post


Link to post
Share on other sites
  • 0

Hello there, :) 

 

Since you got the answer, i will go ahead and move this topic to solve topics. 

If you have anymore issue in the future, feel free to contact us again 

 

Sincerely,
Beenz.

TruckersMP - Support 

 

//Locked and moved to Solved Topics

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...